cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Memorable Member
Memorable Member

Error: Variables - Set Variable "The request content was invalid and could not be deserialized:"

I get error about Variables - Set Variable action.

 

Error message:

The request content was invalid and could not be deserialized: 'Error converting value "SetVariable" to type 'System.Nullable`1[Microsoft.Azure.Flow.Templates.Schema.FlowTemplateOperationType]'. Path 'properties.definition.actions.Set_variable.type', line 1, position

 

Repro step:

1. Trigger : manual button.

2. Action : Variables - Initialize variable ( Name = Count, Type = Integer, Value = 0 )

3. Action : Variables - Set variable ( Name = Count, Value = 1 )

4. Action : Alert the teams

5. Update flow.

6. Get Error message1.png

 

 

 

When the action "Set variable" remove, I can update well.

I want to use "Set variable" to do more by Microsoft Flow.

 

Regards,

Yoshihiro Kawabata

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi all,

 

The deployment with this fix is currently rolling out. Assuming no delays, it will be available in all regions Monday.

 

We appreciate everyone's patience in resolving this!

 

Thanks,

Travis

View solution in original post

22 REPLIES 22
Community Support
Community Support

Hi @yoshihirok,

 

I am able to reproduce your issue. I will try to report this to the pg and will update you once I got any information.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thank you @v-monli-msft for your repro, and report.

 

I am waiting any update about this issue.

 

Regards,

Yoshihiro Kawabata

 

I got the same error when "initialize variable" and then "set variable", the only difference is the variable I tried to define and set is a string instead of an integer.

Hope it helps

.

Hi @efialtes

 

Thank you for reproduce this issue.

 

Yes, This issue happen both variable type , Integer and String.

 

Regards,

Yoshihiro Kawabata

Hi @yoshihirok i have this issue too, i think it's a 'global bug'. I used the Increment to workaround this bug, and it worked pretty good

 

Thanks to report.

 

Regards,

 

Gustavo Moraes


Did I answer your question? Mark my post as a solution!

Gustavo Moraes, o astronauta brasileiro do Flow!


I've got the same error. The increment does not work for me because I'd like to work with strings.

 

Is there a solution for this?

@vfortes1depend than you need you can use Compose with 'if' methods inside.Variables right now is only for integers and floats. If you can open a topic about your need and print some pictures we can help.

 

Regards,

 

Gustavo Moraes


Did I answer your question? Mark my post as a solution!

Gustavo Moraes, o astronauta brasileiro do Flow!


Hi @gamoraes,

 

Thank you for reproduce this issue.

and I used the Variables - Increment.

 

and When I can use Set Variable action, Do more by Microsoft Flow.

 

Regards,

Yoshihiro Kawabata

Hi @vfortes1

 

Thank you for report this error.

and I think too, about some scenario need Variables - Set Variable action.

 

I am waiting solve this error.

 

Reagards,

Yoshihiro Kawabata

 

 

 

 

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (5,652)