cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Excel Connector - OneDrive (Business) switches to the wrong table on its own

I'm using the Excel business connector in Flow in order to create / update / delete rows in a table on OneDrive. I'm using PowerApps to collect the data and send it to Flow, which then performs the updates. Everything works, except periodically, seemingly on its own, I'll receive an error in response to submitting data to Flow - when I check it out, I find that I'm getting the errors because Flow is trying to update the wrong table (a different table in the same workbook).

 

I'm not doing anything to change the table connection, either in PowerApps or Flow - I can't think of a reason why the connector would switch to another table other than a bug.

 

Any advice or help?

4 REPLIES 4
Highlighted
Community Support
Community Support

Hi @awheeler ,

 

Could you please share a screenshot of your flow?

Could you please share more details about the error message?

Could you please explain more details about your scene so we could reproduce the issue?

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

Highlighted

Hello, the same thing happens to me and what happens to me, for example, is that in one step (list rows of an Excel table), the name of the table changes itself. I save the flow with a table name and after a while after editing or executing the flow the name of the table is no longer the one I put, another table from the same book appears.
Thank you very much

Alberto.

Highlighted

thankfully, I saw this issue, as I thought I was seeing things...   but I do not see any resolution or workaround.

I've 52 flows for 52 countries - with three conditions in each.

In each of those conditions, I have two steps where I update excel into either Table1 or Table13. 

 

This was working well for the last 10/11 months, but since last Thursday, I've noticed failing flows. 

I fixed one of those on Friday - so had to delete out the step 'Update a row' and completely rebuild it (3x2) six times.

 

When I look into those, I see that the updates from the country approvers is being sent to the wrong table and therefore failing.

 

Would greatly appreciate any help with this, as fixing 6x52 flows is not appealing to me 😞

thanks in advance.

Highlighted

So, three weeks since I posted on this.. 

 

I've since corrected my 52 Country flows and all was good again, until today, when I find that all 52 flows have once again switched their outputs to the 2nd and wrong table in my excel file, and so are failing. 

 

But, another piece of the puzzle has been revealed. 3 weeks ago I was off work as I was yesterday and to cover the requests coming in on those flows, my colleague, who is based in the US was covering. I'm in Ireland. He's not editing the excel, but only copying data out of it and as it's on OneDrive, it AutoSaves.  So, I wonder would his excel settings (version, setup, format) have anything to do with this.  I still cannot figure out how or why MS Automate is systematically changing a table I've selected, with another.

 

Ideas/thoughts/fixes?

thanks.

John 

04082020_105139.jpg

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Users online (11,333)