cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Bestebreurtje
Helper I
Helper I

Flow Edit Item does not show all Managed Metadata Termset choices

 

When I start a SharePoint Edit Item step and enter a TermSet /  MMD choice not all items are showned in the drop down list.

 

If i enter a Custum value which exists in de Termset if gives a Error when running the Flow. See details Below.

 

Why isn't the full Managed Metadata list available and wihy is the flow stopping when I use a existing value. 

 

 

MMD Field.png

 

 

 

{
  "status"400,
  "message""The data returned from the tagging UI was not formatted correctly\r\nclientRequestId: b59092eb-c7e5-4936-b87e-09948355844a\r\nserviceRequestId: e56a779e-0098-6000-0748-eae192ef62fb"

5 REPLIES 5
v-yuazh-msft
Community Support
Community Support

Hi @Bestebreurtje,

 

I have made a test on my side and have created a metadata column with thirteenTerms, and don't have the issue that you mentioned.

The thirteen Terms would all available in the Update item action on my side.

 

How many terms do you have?And how many terms are available in the Update item action on your side?

 

Please share more details so we would try to provide a proper workaround for you.

 

Best regards,

Alice

 

 

Thank you Alice for contacting me.

 

It looks likes it's stop showing items beyond 20. This termset contains more than 50 items.

 

Beste Regards,

 

Jeroen

Hi @Bestebreurtje,

 

I have made a test on my side and the issue is confirmed on my side.the flow “update item” action does not show all Managed Metadata Termset choices when the Metadata Termset choices are more than beyond 27.

 

I have created a Metadata Termset with 30 choices on my side,the Metadata column in the "Update item" would only show 27 choices and wouldn't show all of the choices as screenshot below:

Capture.PNG

 

I would post this issue to my product team, if the issue is solved, I will reply here.

 

 

Best regards,

Alice

It seems the issue still exists in Flow and it is the same when using poweapps

I am also experiencing this issue.  As a work around I was able to use a manual entry which consisted of the term name| term ID.  This allows me to write to that field, but it seems to prevent it from writing to any remaining fields after that.  The worflow shows that it successfully completed and it even says that all fields were updated, but that is not the case on the document in SharePoint.  The terms that I can select (first 20 terms) all work properly.  An update on this would be appreciated.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (1,471)