cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Resolver I
Resolver I

Flow Error: "[connection] cannot be evaluated because property '[...]' not available

I wish that Mark did not mark "recreating the Flow" as the answer for this post because this bug still persists.

 

The closest way I've been able to recreate this issue on a consistent basis is to create a flow with a given set of connectors (SharePoint, OneDrive, etc.). The Flow can work flawlessly and seem great. Then, if I go back and now want to add an additional connector (custom or OOTB such as Outlook) I will get an error that the given connector is not available. It'll read like the following:

 

Unable to process template language expressions in action 'Send_an_email_notification_2' inputs at line '1' and column '2505': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_sendmail']['connectionId']' cannot be evaluated because property 'shared_sendmail' doesn't exist, available properties are 'shared_excelonlinebusiness, shared_onedriveforbusiness, shared_sharepointonline'. Please see https://aka.ms/logicexpressions for usage details.'.

 

 

The Flow originally was created with SharePoint, Excel Online, and OneDrive (as seen in the available properties listed in the error). Then once I went to add the Send Mail connector a week later to just send a simple notification email, it reports that it "cannot be evaluated..." because the property / connector doesn't exist....

 

BUT I JUST ADDED THE CONNECTOR RIGHT TO THE FLOW. HOW IS IT NOT AVAILABLE?!?

 

Flow absolutely has a bug handling connectors (seems to be consistently related to OneDrive for Business associated Flows if that helps narrow it down). Please don't tell me to just re-create it.

 

11 REPLIES 11
Highlighted
Resolver I
Resolver I

Re: Flow Error: "[connection] cannot be evaluated because property '[...]' not available

Also to note, if I go to the Connectors page of the Flow. I get an error reading "Cannot read property 'properties' of undefined, however doesn't show me what is undefined?

 

Flow Connection Undefined Error.JPG

Highlighted
Community Support
Community Support

Re: Flow Error: "[connection] cannot be evaluated because property '[...]' not available

Hi @stormea,

 

What’s your current situation?

 

How did you add other connectors to an existing flow?

 

Did you try to add an action in the flow?

 

Could you share more details to help reproduce this issue?

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Resolver I
Resolver I

Re: Flow Error: "[connection] cannot be evaluated because property '[...]' not available

Hello @v-yamao-msft, I've been able to narrow it down more. It looks like the Flow has to be created with a PowerApp Trigger and a given amount of connectors. Once I save, and then re-open the Flow and try to add an additional (new) connector, this is when the error pops up.

 

Highlighted
Advocate V
Advocate V

Re: Flow Error: "[connection] cannot be evaluated because property '[...]' not available

The workaround is to export the Flow, then re-import it as new. I found the workaround here when I encountered the same issue myself: https://powerusers.microsoft.com/t5/Building-Flows/property-shared-office365-doesn-t-exist/m-p/12984....

Advocate V
Advocate V

Re: Flow Error: "[connection] cannot be evaluated because property '[...]' not available

Recently discovered an easier workaround, though not as reliable: Test Flow with manual trigger.

 

2018-10-30 16_37_34-OneNote.png

 

After clicking the "Test Flow" and selecting "I'll perform the trigger action", a dialog appears that will map connections.

 

2018-10-30 16_41_01-Photos.png

 

This has worked for me once.

 

Highlighted
Anonymous
Not applicable

Re: Flow Error: "[connection] cannot be evaluated because property '[...]' not available

Yeah, got the same issue but with Flow Trigger. As soon as I set another trigger, the problem is resolved.

Highlighted
Advocate II
Advocate II

Re: Flow Error: "[connection] cannot be evaluated because property '[...]' not available

I came across the same issue and I think I found the reason due to this is happening. If you add a new connection in the flow after creating it and use the test cases which are running on the previous connection configuration then it will generate this error.

 

Because in the previous run it doesn't have access to the newly added connections.

 

Solution:- Don't use the previous test case for testing it. Trigger the flow manually or perform the action which triggers the flow.

 

If this answer helps you please give a thumbs up.

 

Thank You.

Highlighted
Advocate II
Advocate II

Re: Flow Error: "[connection] cannot be evaluated because property '[...]' not available

@Naveen_772 that was the answer I have been looking for for two days!!!! Once I started the Flow from scratch it worked perfectly. THX a 1000 times 😊

 

/Frank

Highlighted
Frequent Visitor

Re: Flow Error: "[connection] cannot be evaluated because property '[...]' not available

Awesome, thanks.  I did edit the flow after I had assigned the flow run to the button and got the same error.  I had to remove flow run function and add it back and it worked.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (1,361)