cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flow Fails trying to send Approval Email

Was doing some troubleshooting of another issue in flow (detailed well in this thread) when i started getting another error. The previously affected flow now just fails instantly.

 

The only thing changed before this error started happening was that I changed the Person column in the list where the "Get Item" runs beforehand to not compulsory. The Get Item action runs succesfully though and I have not altered anything else... anyone have any ideas what may be happening here?

 

 

InvalidTemplate. Unable to process template language expressions in action 'Send_approval_email' inputs at line '1' and column '1576': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_office365']['connectionId']' cannot be evaluated because property 'shared_office365' doesn't exist, available properties are 'shared_sharepointonline'. Please see https://aka.ms/logicexpressions for usage details.'.

 

flowError2-1.PNG

6 REPLIES 6
v-yamao-msft
Community Support
Community Support

Hi rolycityaccount,

 

To test this issue, I create a flow the similar with you. There is also a People and Group column in my list, I have no other special settings.


Then I add the flow to a button on an app. When I click the button to run the flow, it runs succeed.

 

My flow configuration and the run status:
4.PNG

3.PNG

 

Could you try my steps to see if it works for you?

 

If you are still getting this issue, please provide the URL of your flow for a further investigation.


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hi @v-yamao-msft,

 

Solved this by removing the flow from powerapp which triggers it, then re adding it again.

 

Not sure why but it worked. Thanks for your help!

I just hit this same issue where start an approval gives me the following error:

 

Unable to process template language expressions in action 'Start_an_approval' inputs at line '1' and column '1872': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_approvals']['connectionId']' cannot be evaluated because property 'shared_approvals' doesn't exist, available properties are 'shared_office365'. Please see https://aka.ms/logicexpressions for usage details.'.

 

It seems to be a problem when running Approval steps within a Flow that is started by a Powerapps trigger

 

I ccreated a copy of my flow and then reloaded the app in PowerApps Studio. 

 

 

 

Has the product team worked on this yet as I just got the same issue?

I expect nothing from them. This has been an issue for over one and a half years.

 

I don't understand why they can't fix these issues rather than spending time changing names of their products. 

 

 

 

 

I am facing the same issue , is there any good solution for this?

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Users online (2,297)