cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flow doesn't work for Shared Mailbox; Error:invalid mailbox but mailbox exists and works fine

Created a Flow to Save emails to SP, when a new email arrives in an assigned Shared Mailbox (inbox). Each time I see userid or mailbox error such as this one:

 

User account or mailbox does not exist. clientRequestId: 26c624ad-2384-4d07-9d79-1114c6961ffe serviceRequestId: 739169e4-68b5-453d-bd3f-133cce15dba3

 

I tried the no semi-colon method ( ; ) didn't work. 

 

Checked with the team, I have full access to the shared mailbox. Can someone please review and fix the Shared Mailbox issue at the earliest?

SharedMailbox2.jpg

3 REPLIES 3
v-xida-msft
Community Support
Community Support

Hi @Anonymous,

 

Could you please share a screenshot of your flow's configuration?

 

The error message told that the email address that you filled within the Mailbox Address field is not existed. Please check if you have provided a proper shared email address within the Mailbox Address field of the "When a new email arrives in a shared mailbox" trigger.

 

I have made a test on my side and don't have the issue that you mentioned. My flow's configuration as below:13.JPG

Note: The email address that you specified within the Mailbox Address field of the trigger should ends with a semi-colon ( ; ) .

 

The flow works successfully as below:14.JPG

 

 

In addition, please check if the account that you create a connection to the "When a new email arrives in a shared mailbox" trigger has enough permission to access the shared email address that you specified (Check if your account is a member of the Shared mailbox).

 

Please also take a try to clear cache of your browser and try your flow again to check if the issue is solved.

 

Best regards,

Kris

 

 

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hi @v-xida-msft

 

Did you say the email in the Shared Mailbox field 'should' end with semi-colon?

 

I saw a whole another post on this channel saying, no semi-colon will work. I am a little confused now. Can you please confirm - semi-colon or no semi-colon?

 

Thank you very much.

Anonymous
Not applicable

Hello again @v-xida-msft

 

Tried using a different browser to get rid of any cache memory issues.

Tried with semi-colon - didn't work

Tried without semi-colon - didn't work.

 

 

 With a semicolon.jpgWithout semicolon.jpg

 

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,947)