cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
LionelCharley
Frequent Visitor

Flow failing at the approval section:Error code: 'ApiManagementAccountNotAllowed'

I have simple flow when a new request is created in the SharePoint list, it triggers approval. Approver gets email to approve and status is updated back in SharePoint list.

 

Flow was failing at the approval section and below error was displayed.

 

Forbidden. The request failed. Error code: 'ApiManagementAccountNotAllowed'. Error Message: 'Call not allowed from api management account 'msmanaged-na'.'

 

Can someone help me on this.Capture.PNG

 

45 REPLIES 45
tdmar3
New Member

Same issue here. 

klp65
New Member

Same issue with one of my key workflows.

The version of the approval step in my workflow is deprecated.  I tried adding the "Start and wiat for an approval" step into the workflow, and ran into a problem.  This same issue occurs on a completely new flow that I created to test it.  The widget in the designer displays a drop-down for "Approval type", but when I try to select an approval type, I get an error messgae as the first item in the menu: "Could not retrieve values, undefined."

 

This is clearly a bug -- there is no sense having a menu without values.  The problem appeared today -- the original workflow was working fine yesterday.  I hope MS will fix both problems IMMEDIATELY.  This is breaking production code that has been stable for a long time.

 

 

TCambs
Power Automate
Power Automate

I'm aware of the issue and am currently working on a fix.

Thank you all - Issue is resolved now.

Thank you, I've confirmed everything's working for me again.  I appreciate the quick turnaround!

What was the fix for this issue? I am using the "Start and wait for an approval" action and I too got this issue the other day randomly. Most other times have yielded no error/issue, but one random time I got this error (same as OP).

@Michelangelo  The fix for the issue was that I needed to redploy some metadata for the Approvals connector to the proper regions.

SmeetaJ
New Member

SmeetaJ_0-1631554137975.png

 

Approval not working.

Same flow was created a week ago and it worked just fine.

Please Help

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Users online (1,330)