cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Heli2911
Frequent Visitor

Flow is not always triggered every item created or modified

Hi,
I have flow with trigger 'When an item is created or modified' for sharepoint list. When I tested, the logic and the results works fine.
Moreover, recently I realize that the trigger is not always triggering every item created/modified. Sometimes it trigger directly, sometimes it is not triggered and will run together with the next trigger. 

I have tried to change the 'Concurrency Control', but the issue still there.

 

Is this phenomenon normal ? If not, please give me advise how to fix it.

5 REPLIES 5
v-litu-msft
Community Support
Community Support

Hi @Heli2911,

 

Did you ever add any condition in the trigger 'When an item is created or modified'?  

Such as a special field has changed will trigger the Flow or some specified fields meet to trigger the Flow.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-litu-msft ,

I don't add any condition in the trigger as below :

Capture.PNG

 

Hi @Heli2911,

 

Could you please try to delete the old connection of the SharePoint? And try to delete the old trigger.

Did you create the Flow from a template?

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I don't use template, I start from blank.

And I've created new simple flow and it also happened as below :

CAPTRUE2.PNG

Capture.PNG

On this flow I experienced that when I created first new item, the trigger was not recognized. Then I created the second new item, then the flow recognized the trigger and run both triggers together.

 

Is there any setting that I should configured ? Because I think it happened in all of my flows.

Hi @Heli2911,

 

I tried to reproduce the Flow and the issue you met, but I couldn't make it.

I create a brand new list and a new Flow when an item is created or modified, but it is triggered as soon as an item created.

There is no setting about the trigger delay or other associated configuration.

I guess it is a temporary issue caused by Sharepoint service, does your Flow still exist the problem?

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,697)