cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Flow not Triggering (Sharepoint Modified)

I have a flow that is connected to a large, heavily used Sharepoint O365 List. Up until late last week (I believe it was 5/25/17 around 2:30pm-ish), it worked like a dream. 100% success. 

 

The flow is designed to pick up modified items, do a check against a "Status" field, and based on that, either send an email or skip. Due to the fact that I'm statusing, and on each status change I save the item, it kicks off multiple flows per item. I have 3 statuses, New, In Progress, and Completed. When it gets moved to Completed, it sends the emails.

 

Like I said, up until last Thursday, it worked like a dream. It would trigger on both in progress and completed, and run the whole flow on completed. A+. Well, silly ol' me introduced a second, smaller workflow on the same list to test something, as opposed to messing with my perfect child. Thats when the problems started. 

 

I noticed my new flow only triggered about 2/3rds of the time. It would detect the "In Progress" save, but then never detect the "Completed" save. It wasnt erroring out, flows just was NOT triggering. Unfortunately, the trend has spread to my heavily used email workflow. 

 

To get a sample size, I scrolled through my email to see what my sent box looked like. In 2 days and a few hours this morning, there have been a total of 337 items "Completed". Of those 337, ONLY 215 have triggered on the modify containing the "Completed". Thats a 64% success rate folks. Thats TERRIBLE

 

Here is what I have done to troubleshoot so far:

  1. Deleted the second, smaller flow
  2. Turned off, and then turned back on the flow in question
  3. Reset the "Connection" user, just incase something funky was going on there. 

 

No, the list name hasnt changed. Nothing significant has changed to the list. I havent modified the flow (outside of the connection user stuff). It simply went from perfect to garbage. Has anyone else experianced this, or can a mod/admin tell me a solution? I've done everything I can think of short of deleting the flow and starting from scratch, but I dont want to go through all that trouble and it still not work. It took forever to write, because I have several versions of HTML emails going on...

 

119 REPLIES 119
Helper I
Helper I

Has this issue been resolved. I am encountering same issue?

Regular Visitor

I also have this same issue.  The Flow that I have created for created or modified items on my Sharepoint list only triggers sometimes.  I have been unable to determine what is causing this or the pattern why.  The Flow does not error out it just does not run at all. 

Can you please paste the sharepoint site and the flow id and we can take a look? It is not expected that triggers do not work reliabily.

I've started looking at this with the SharePoint team, but in order to investigate any specific cases we need to know rough timestamps (with timezone) that changes were made on the list so we can compare with trigger operations to see why there were delays. Please post here or feel free to reach out by email. 

What is your direct email?

Please send the requested info to dblyth AT microsoft DOT com

Regular Visitor

I replied back to you on Monday but have not heard anything. Please advise.

I dont see anything on my mailbox.

@cmaly @npokhrel123 These are all typically different root causes, not one single issue. These are all still being investigated.

 

The more data that is provided, the easier the investigations are. If you have more instances of the exact day and time changes along with the corresponding (delayed) Flow run URL, we can investigate issues more easily. 

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (8,120)