cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate IV
Advocate IV

Re: Flow not Triggering (Sharepoint Modified)

Excellent, thanks - please let us know when fixed so we can try again.


Adam

Highlighted
Frequent Visitor

Re: Flow not Triggering (Sharepoint Modified)

Hi,

 

@v-yamao-msft does this issue also applies to the created trigger? In our case both, SharePoint Modified and SharePoint Created, triggers are not working at all. Flow does not even log something in the run history.

Highlighted
Community Support
Community Support

Re: Flow not Triggering (Sharepoint Modified)

Hi All,

 

The fix for the issue has been rolled out. I test this on my side and it is working fine. Please try it on your side and let us know if you are still seeing issues.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate I
Advocate I

Re: Flow not Triggering (Sharepoint Modified)

Hi Mabel!

 

I'll have to monitor this for a bit to make sure it's working as intended, but so far it's looking good! 

 

Thank you for the speedy fix!

Highlighted
Advocate I
Advocate I

Re: Flow not Triggering (Sharepoint Modified)

Hi Mabel!

 

I checked back all to first thing Monday morning, and my flow has been working at 100% capacity again. 

 

Thanks for all the hard work!

Highlighted
Microsoft
Microsoft

Re: Flow not Triggering (Sharepoint Modified)

Now, not one of my flows are working, all of them interact with SharePoint in some manner.  The triggers haven't fired for on create or on updated for about 24 hours now.  Did this fix actually cause more issues?

 

Highlighted
Frequent Visitor

Re: Flow not Triggering (Sharepoint Modified)

Same here - still having issues that the created or modified triggers are not fired.

Highlighted
Community Support
Community Support

Re: Flow not Triggering (Sharepoint Modified)

Hi @inthisidrown@Adrian_Chrobok

 

None of the two triggers work on your side? Do you get any error messages?

 

Could you provide the URL of your Flow? You could get it when editing the flow.


If possible, please also provide your site/list information for a further investigation.

 

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Flow not Triggering (Sharepoint Modified)

Hi @v-yamao-msft,

 

Unfortunately none of the both are working. Flows with this triggers which are working fine before the 1st of June are now not working at all. For testing purposes I created now a new Flow with the same trigger and just a "send an email" action and I'm getting this after saving it for the first time:

 

2017-06-14_10h41_59.png

 

The Header:

 

{
  "Pragma": "no-cache",
  "x-ms-request-id": "3d4982c7-221c-4f2f-a0f6-ba8647de133e",
  "Timing-Allow-Origin": "*",
  "Cache-Control": "no-cache",
  "Date": "Wed, 14 Jun 2017 08:41:40 GMT",
  "Set-Cookie": "ARRAffinity=fe5113e98f6e48887513ffe16a2381e9c75e4bd9edb15ae186c00e39b7d9368e;Path=/;Domain=sharepointonlineconnectionprovider-northeurope.db3-ase-001.p.azurewebsites.net",
  "Server": "Microsoft-IIS/8.0,Microsoft-HTTPAPI/2.0",
  "X-AspNet-Version": "4.0.30319",
  "X-Powered-By": "ASP.NET",
  "Content-Length": "281",
  "Content-Type": "application/json; charset=utf-8",
  "Expires": "-1"
}

 

 

The Body:

 

{
  "status": 502,
  "message": "Secondary field with ID \"{2CB5EC60-8D82-4C4B-B59B-CB7C1B583917}\" does not have a primary field",
  "source": "/_api/SP.APIHubConnector.GetNewListItems",
  "errors": [
    "-1",
    "Microsoft.SharePoint.SPConnectorException"
  ]
}

 

URL to the Flow: https://flow.microsoft.com/manage/environments/Default-cf404960-c50f-46d2-8bf3-a3c957283b86/flows/31...

 

Whats very courious: between the 1st and the 2nd of June all of our Flows were edited at the same time, but noby of my team has done any modifications. Sind this time, the - as already mentioned - previosly nicely worked Flows are no longer working. The fact, that not even a failure or something else is logged into the Run History is also very interesting ...

 

Screenshot is from the 2nd of June - luckily the most important and only Flow with none of the both triggers is still working Smiley Wink

 

2017-06-02_20h39_05.png

Highlighted
Advocate IV
Advocate IV

Re: Flow not Triggering (Sharepoint Modified)

Hi @v-yamao-msft

 

I've done some testing this morning and found the following...

 

SharePoint list #1 with a "modify" flow previously not triggering when some of the columns were modified. However made 10 changes to various fields and all now behaving as expected.

 

SharePoint list #2 with seperate "create" and "modify" flows both which sends emails. I've recorded the times which the flows ran and the emails were received below. As you can see two of the modify flows were only triggered when a subsequent change was made (#6 and #10).

 

 Create FlowCreate EmailModify FlowModify Email
List item #4 created 10:1510:1510:1510:1510:15
List item #5 created 10:1610:1610:1610:1810:18
List item #6 created 10:1810:1810:1810:4110:41
List item #7 created 10:4110.4110.4110.4110.41
List item #8 created 11:1111:1111:1111:1111:11
List item #9 created 11:1311:1311:1311:1311:13
List item #10 created 11:1511:1511:1511:2011:20
List item #11 created 11:2011:2011:2011:2011:20

 

Thanks

Adam

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Users online (7,505)