cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Prashanthan
Frequent Visitor

Flow ran successfully but didnt receive email

Hi,

I created a simple flow as below:

 

Trigger from Powerapp button 'onselect'

Passing 4 parameters (eamil to, subject, body1, body2)

 

The flow shows it ran successfully. But i'm not receiving any emails.

Few weeks back when i tested with a hardcoded email, it worked. But that also doesnt work now.

Can someone help to understand the issue?

 

image4.png

 

image1.png

Image3.png

Thanks

Prash

6 REPLIES 6
v-yamao-msft
Community Support
Community Support

Hi @Prashanthan,

 

Thanks for feedback.

The issue could be reproduced by me.

I will help report it and back to you later.

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks @v-yamao-msft,

 

I reported the issue internally within the organisation.

They said they received the email on a new flow they have created.

 

So gave mine to them as a package to investigate.

Hope either you or the internal support team can recreate it and the find a solution.

 

In some other support request i saw someone had a slightly similar issue (in their case they got the "Invalid template..." error message).

The user resolved that issue by re-creating the flow again.

 

In my scenario, i didnt get any failures except once i got a similar "invalid template" issue in only one of the run.

when i re-ran the failed one, it didn't work. but new runs were successful.

 

So safe side, i created a new flow with exactly the same details (the current one). This didnt give any erros but as i mentioned before, not getting the email.

 

Thanks

Hi @Prashanthan,

 

I have some updates for you.

Output is always empty for action send an email notification, even when mail is sent (and received).

If possible, please share the customer’s email address, we can help check if they have ended up on the unsubscribe list.

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-yamao-msft,

 

Thakns for your reply.

I tested it with my personal email address and receiving the emails for the same flow.

So as you explained below it seems the office email address may have ended up in unsubscribe list.

 

Since i wanted to send an email notification to the 'assigned user' (will be passed through Powerapps) of a case, how i can make sure none of these email addresses end up in unsubscribe list?

 

Thanks

Prashant

What was the solution in this case? My flow continuously tests successfully but I am not getting an email. @v-yamao-msft @Prashanthan  

GVenkatesh
Regular Visitor

I am also getting the same error, working in power apps. when I click on a button manually email should trigger accordinly to the recipients.

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Kudoed Authors
Users online (2,411)