cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mpoppe
Level: Powered On

Flow when new email arrives -> attachment contentbytes :null

I find some strange behaviour in Flow.  I have a flow with trigger: When a new email arrives.  The emails concerned have attachments, which should be send to another recepient by the flow.  In the trigger, I set 'Hase attachments' and 'include attachments' both to Yes. 

Flow1.jpg

 

When I run the flow, I get the error message: Parameter 'Attachment Content' cannot be null or empty.

 

In the run history, I see that the email settings : Has attachments and Include attachments have been set to false:

 

flow2.jpg

 

Could this be a bug???   Any help would be very much appreciated! 

 

Thanks,

Miriam

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support Team
Community Support Team

Re: Flow when new email arrives -> attachment contentbytes :null

Hi @mpoppe ,

 

What’s your current situation?

 

Could you take another try with it?

 

I have just made a test on my side, the issue could not be reproduced.

 

Trigger “When a new email arrives” works fine with Has Attachment and Include Attachments set to Yes, and they won’t be set to False once triggered.

 

Please check my testing results likes below:

1.PNG2.PNG

 

It seems that there are some updates on Flow, I am afraid that the issue you occurred might be temporary.

 

Please run it again on your side, and feel free post back if the issue still exists.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Highlighted
Community Support Team
Community Support Team

Re: Flow when new email arrives -> attachment contentbytes :null

Hi @mpoppe ,

 

What’s your current situation?

 

Could you take another try with it?

 

I have just made a test on my side, the issue could not be reproduced.

 

Trigger “When a new email arrives” works fine with Has Attachment and Include Attachments set to Yes, and they won’t be set to False once triggered.

 

Please check my testing results likes below:

1.PNG2.PNG

 

It seems that there are some updates on Flow, I am afraid that the issue you occurred might be temporary.

 

Please run it again on your side, and feel free post back if the issue still exists.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

mpoppe
Level: Powered On

Re: Flow when new email arrives -> attachment contentbytes :null

Hi Mabel,

Thanks for your response.  Rerunning the flow gave me the same problem.

What I did next, was delete the first step (trigger), and recreate it exactly the same.  After that the problem was gone.

So I guess it was indeed temporarily and solved with an update of flow.

 

Best regards,

Miriam

courtenayW
Level: Power Up

Re: Flow when new email arrives -> attachment contentbytes :null

Found this while searching for 

"ContentBytes": null
after seeing an error. I've just found the same thing, that changing to "true" for include attachments, then resubmitting the failed email shows "False" in both fields. Is it not possible to re-submit the failed one with the changes I made?

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 371 members 5,666 guests
Please welcome our newest community members: