cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flows not pulling some user profile properties correctly.

Hi all,

 

Found this error happening on some new flows I've created. I'm using a Flow to update a SharePoint list item with a given user's job title. I can pull their display name and email just fine but the job title is always returning null.

 

I am currently able to access these properties in PowerApps and they appear to use the same Microsoft.Azure.Connectors.SharePoint.SPListExpandedUser object when referencing the field so assuming this is a bug isolated to Flow at this point and time.

 

This has been raised in the past elsewhere here: https://powerusers.microsoft.com/t5/Building-Flows/Dynamic-content-always-returns-empty/m-p/42376#M3...

 

Nothing seems to have been done about it so far so I thought I would raise it in this "found a bug" forum.

 

Cheers

 

Here is an extract of the Author field from the last flow run this morning:

"Author": {
    "@odata.type": "#Microsoft.Azure.Connectors.SharePoint.SPListExpandedUser",
    "Claims": "i:0#.f|membership|roly@company.com.au",
    "DisplayName": "Roly",
    "Email": "roly@company.com.au",
    "Picture": "https://company.sharepoint.com/eforms/_layouts/15/UserPhoto.aspx?&Size=S&AccountName=roly@company.com.au",
    "Department": null,
    "JobTitle": null
  },
  "Auth
3 REPLIES 3
Community Support
Community Support

Hi rolycityaccount,

 

I can reproduce this issue on my side. When create a flow to get user’s Department and JobTitle, they are always returning null.

4.PNG

 

I will report this issue on my side and back to you once I got any updates.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Thanks Mabel, do let me know if there's any news on this one. Keen to get it working.

 

Cheers

Hi rolycityaccount,

 

Thanks for your understanding. I have reported this issue on my side.
I will back once I got any updates.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (4,196)