cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Forms doesn't trigger flow

I have a form that triggers a flow to send a mail with the details from the form

It will only trigger when I save the flow.

When a submit a form, nothing happens.

 

I have error codes and it works fine when I test it in flow, and as I said, when I edit the flow and save it, it will trigger and send the mails with reponses

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Forms doesn't trigger flow

Hi @runekjensen,

 

Glad to hear that it is working now.

Currently Microsoft Flow doesn’t support group forms. If you need this feature, please feel free submit a request on Flow Ideas Forum at here:

https://powerusers.microsoft.com/t5/Flow-Ideas/idb-p/FlowIdeas

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

8 REPLIES 8
Highlighted
Community Support
Community Support

Re: Forms doesn't trigger flow

Hi @runekjensen,

 

Are you working with Microsoft forms?

Could you share a screenshot of your flow?

What’s the error code you’ve got?

What do you mean by “it will only trigger when I save the flow”?

I have created a flow to send an email when a response is submitted in Microsoft Forms which is working great.

Whenever a response is submitted, it will be triggered and will send out the email with responses.

Please check the following flow for a reference.

1.PNG 

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Forms doesn't trigger flow

Hi @v-yamao-msft

 

See below

 

Are you working with Microsoft forms?

Yes

Could you share a screenshot of your flow?

Well yes...but I can't seem to upload it. Do I have to upload it to a another service in order to link it here?

What’s the error code you’ve got?

I do not get an error code - and now it does trigger....but with a considerable delay on several hours

What do you mean by “it will only trigger when I save the flow”?

If I edit the flow and save it, it will trigger and send out mails at once

I have created a flow to send an email when a response is submitted in Microsoft Forms which is working great.

Whenever a response is submitted, it will be triggered and will send out the email with responses.

Well the only difference between you and my flow is that you have this "Apply to each" and the get response details. Mine is the same start but then it just directly to send e-mail with the details.

Again, this wokrs, but sometimes with several hours delay

 

 

Highlighted
Community Support
Community Support

Re: Forms doesn't trigger flow

Hi @runekjensen,

 

Thanks for quick updating.

Please try adding the action Get response details under the trigger When a response is submitted, then you will get the email once the responses submitted.

Please take a try with it.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Forms doesn't trigger flow

Ok, but I don't have the option as shown in your workflow "Response ID" i only have the user inputs to choose from

Can I use something else?

Highlighted
Frequent Visitor

Re: Forms doesn't trigger flow

Nevermind. Seemed like I hnad to start from scratch to make it work

Highlighted
Community Support
Community Support

Re: Forms doesn't trigger flow

Hi @runekjensen,

 

Please share a screenshot on your flow so that I can help figure out the issue.

Click the Camera icon to upload an image on the forum.

1.PNG

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Forms doesn't trigger flow

It seems like it works now 🙂

 

If I move the form to group forms...will it still work. Do you know that?

Highlighted
Community Support
Community Support

Re: Forms doesn't trigger flow

Hi @runekjensen,

 

Glad to hear that it is working now.

Currently Microsoft Flow doesn’t support group forms. If you need this feature, please feel free submit a request on Flow Ideas Forum at here:

https://powerusers.microsoft.com/t5/Flow-Ideas/idb-p/FlowIdeas

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (8,524)