cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
garywalker
Helper I
Helper I

Getting multi value managed metadata

Hi,  

Im using an On Premise Data Gateway to move files from an On Premise SharePoint to an Online SharePoint for a client.

 

my flow successfuly picks up changes to the On Premise library and addes the files to the online library.

However when using Get File Properties action within the flow,  any field that is of type Managed Metadata, and has the mutli value option selected has the value of 'null' regardless of what was actually in the column.

i do not get this issue if the mutli value option is not selected.

 

in the image below Application, and Document_x0020_Category are both multi select managed metadata columns with data, but nothing is returned, 

Date_x0020_Produced is a single valued managed metadata column and this does return data.

multvaluemetadata.PNG

 

Is this a bug/limitation or am i missing somthing?

 

Regards

Gary 

5 REPLIES 5
v-zhos-msft
Solution Sage
Solution Sage

Hi @garywalker ,

Could you please share a full screenshot of your flow's configuration?

I have made a test on my side.

when I used the 'Get File Properties action, I can get the column value.

It doesn't has the issue your have mentioned.

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

not sure which images you need

 

Flow.PNGFlow Run.PNG

Hi @garywalker ,

I have made a test on my side, and it doesn't has the issue you have mentioned.

Please make sure you have select the same library of the trigger and actions.

Capture2.PNG

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

The Values that i have entered have to be correct, as shown in the screen shots we can see other values coming back,  i can populate all values that are not Multi-Value Metadata fields,  and i can get the file content its self form a later step using the same values.  

I have tried this on my dev tenant, the company tenant and the clients tenant. I get the same result on all.

I have also tried using the 'Sent Http request to sharepoint' step,  this return a collection object in stead of null,  but i can not see how to access the collection.

 

Thanks for your help so far, but i have now started to create a custom dot net solution instead.

I'm getting the same thing.  Connecting to an on-prem list with a multi-value managed metadata column.  Get Items shows null values for every list item, but using a SharePoint HTTP call returns the correct values.

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Top Solution Authors
Users online (1,121)