cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User
Super User

HTTP action, GET, api-version missing error but is there

My flows calls another flow using the HTTP action, with GET - the flow results shown in the images.

The error message in the OUTPUTS image is:

{
"error": {
    "code": "MissingApiVersionParameter",
    "message": "The api-version query parameter (?api-version=) is required for all requests."
  }
}

But in the INPUTS the api-version parameter can be seen! What is going on?

 

Kind regards, John

Flow.HTTP.Inputs.pngFlow.HTTP.Outputs.png

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

As a workaround, removed the Queries definition and added it directly in the URL as &id=291

 

Funny enough, that worked! Can I not use the Queries to provide the id?

 

Kind regards, John

View solution in original post

1 REPLY 1
Super User
Super User

As a workaround, removed the Queries definition and added it directly in the URL as &id=291

 

Funny enough, that worked! Can I not use the Queries to provide the id?

 

Kind regards, John

View solution in original post

Helpful resources

Announcements
New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Users online (67,239)