cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User II
Super User II

HTTP action, GET, api-version missing error but is there

My flows calls another flow using the HTTP action, with GET - the flow results shown in the images.

The error message in the OUTPUTS image is:

{
"error": {
    "code": "MissingApiVersionParameter",
    "message": "The api-version query parameter (?api-version=) is required for all requests."
  }
}

But in the INPUTS the api-version parameter can be seen! What is going on?

 

Kind regards, John

Flow.HTTP.Inputs.pngFlow.HTTP.Outputs.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User II
Super User II

Re: HTTP action, GET, api-version missing error but is there

As a workaround, removed the Queries definition and added it directly in the URL as &id=291

 

Funny enough, that worked! Can I not use the Queries to provide the id?

 

Kind regards, John

View solution in original post

1 REPLY 1
Highlighted
Super User II
Super User II

Re: HTTP action, GET, api-version missing error but is there

As a workaround, removed the Queries definition and added it directly in the URL as &id=291

 

Funny enough, that worked! Can I not use the Queries to provide the id?

 

Kind regards, John

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Users online (6,703)