cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

HTTP action, GET, api-version missing error but is there

My flows calls another flow using the HTTP action, with GET - the flow results shown in the images.

The error message in the OUTPUTS image is:

{
"error": {
    "code": "MissingApiVersionParameter",
    "message": "The api-version query parameter (?api-version=) is required for all requests."
  }
}

But in the INPUTS the api-version parameter can be seen! What is going on?

 

Kind regards, John

Flow.HTTP.Inputs.pngFlow.HTTP.Outputs.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: HTTP action, GET, api-version missing error but is there

As a workaround, removed the Queries definition and added it directly in the URL as &id=291

 

Funny enough, that worked! Can I not use the Queries to provide the id?

 

Kind regards, John

View solution in original post

1 REPLY 1

Re: HTTP action, GET, api-version missing error but is there

As a workaround, removed the Queries definition and added it directly in the URL as &id=291

 

Funny enough, that worked! Can I not use the Queries to provide the id?

 

Kind regards, John

View solution in original post

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Users Online
Currently online: 317 members 6,242 guests
Please welcome our newest community members: