cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Incorrectly configured dynamic content in Outlook 365 "Send an Email (V2)"

There is a bug that was introduced in Outlook 365's Send an Email (V2), where dynamic content was mixed up between the Subject and Body:

 

flowv2.png

 

That's how it's supposed to be, not the vice versa.

 

flowv222222222222222222222222.png

Steps to reproduce:

1) Create or update a Flow;

2) Add a query (e.g., a Kusto or an App Insights);

3) Add the Send an Email V2;

4) Click on Body.

 

Expected results:

Flow allows to insert the results into the email's body.

 

Actual result:

This option is gone.

 

Additional step:

Click on the Subject field: you will see this dynamic content's option. This is not where it's supposed to be (there's no point in inserting results into the subject).

 

Note, this still works in V1.

 

Please fix ASAP.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Incorrectly configured dynamic content in Outlook 365 "Send an Email (V2)"

Hi @Kona ,

 

Please take a try to add a Compose before the "Send an email (V2)" action and save the Body dynamic content from the query as screenshot below:

1.png 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Helper I
Helper I

Re: Incorrectly configured dynamic content in Outlook 365 "Send an Email (V2)"

Thank Gog, the old functionality still works if you do this:

 

floo.png

View solution in original post

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: Incorrectly configured dynamic content in Outlook 365 "Send an Email (V2)"

Hi @Kona ,

 

Please take a try to add a Compose before the "Send an email (V2)" action and save the Body dynamic content from the query as screenshot below:

1.png 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Helper I
Helper I

Re: Incorrectly configured dynamic content in Outlook 365 "Send an Email (V2)"

Thanks Alice, adding Compose works although in my opinion it not an ideal solution since it makes Flows more complicated.

 

P.S. Will this bug with incorrectly mapped dynamic content ever get fixed? Would be nice if this was changed back to how it used to work in V1 or fixed.

Highlighted
Helper I
Helper I

Re: Incorrectly configured dynamic content in Outlook 365 "Send an Email (V2)"

Thank Gog, the old functionality still works if you do this:

 

floo.png

View solution in original post

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (6,941)