cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Invalid Template Error

My Flow was working just fine but all of the sudden, I'm getting this error when creating a file on onedrive business:

 

"InvalidTemplate. Unable to process template language expressions in action 'Create_file' inputs at line '1' and column '2606': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_onedriveforbusiness_1']['connectionId']' cannot be evaluated because property 'shared_onedriveforbusiness_1' doesn't exist, available properties are 'shared_sharepointonline'. Please see https://aka.ms/logicexpressions for usage details.'."


Is anyone else getting the same error?

Annotation 2019-05-30 144409.png

 

6 REPLIES 6
Anonymous
Not applicable

Got it to work. You have to run it from the Sharepoint list (in my case). Right click the line item and run flow.

Hi @Anonymous ,

I am glad to hear that your issue was successfully resolved.

If there is anything else we can do for you, please feel free to post in the forum.

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

RachelRig
Advocate V
Advocate V

Same issue on a Flow triggered by a Powerapps button. I have recreated the entire thing from scratch to no avail. WHAT IS THIS PROBLEM?? Please tell me there's a solution. I cannot use Flow if nothing works!

 

InvalidTemplate. Unable to process template language expressions in action 'Create_file' inputs at line '1' and column '2227': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_sharepointonline']['connectionId']' cannot be evaluated because property 'shared_sharepointonline' doesn't exist, available properties are ''. Please see https://aka.ms/logicexpressions for usage details.'.

Can you explain how you got this to work? I'm having the exact same error but can't figure out how to fix it.

Any chance you've found a solution for this problem? It has me hung up on a project that's under a tight deadline.

Leo_NYC
Helper I
Helper I

i got it to work.....

 

I had the List as one of the owners, when I removed it, it started working.

Helpful resources

Announcements
User Groups Public Preview

Join us for our User Group Public Preview!

Power Automate User Groups are coming! Make sure you’re among the first to know when user groups go live for public preview.

New Super Users

Meet the Power Automate Super Users!

Many congratulations to the Season 1 2021 Flownaut Crew!

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Users online (58,156)