cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Advocate I
Advocate I

Issue with getting Approval comments from Adaptive card in teams

Hi

 

If i create the following Flow: The request for approval adaptive card is correctly posting into the Team channel and the assigned user can approve the item. But any comments they put into the card on approval are returned with a Null value to Flow when i try to post them into a sharepoint list item.

If the approval is done via the flow interface in teams or via the flow website the comments are returned correctly and are posted into the shrepoint list. is this a bug with adaptive cards?

 

e.g.

First.pngsecond.png

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi @jon-w,

 

This bug has already been fixed and is rolling out this week.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

7 REPLIES 7
Highlighted
Community Support
Community Support

Hi @jon-w,

 

Thank you for your feedback!

I have tested on my side, and I found the same issue.

We will report this bug, and find the solution.

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted

Hi @v-litu-msft 

 

Worth also mentioning to the team that, with adaptive card to teams approvals, there is no option to reassign the approval to someone else like there is in the flow interface.

 

Regards Jon

Highlighted

Hi @jon-w,

 

This bug has already been fixed and is rolling out this week.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted

Hi @v-litu-msft 

 

How will i know it's been rolled out - just keep testing "Wait for an approval"?

 

Regards Jon

Highlighted

I've made some tests and I get the same issue today. 

 

The comment added by the approver using the adaptive card in Teams is not reproduced in my email by using dynamic content from "waiting for an approval" > "Responses Comments". 

 

Highlighted

@v-litu-msft 

 

Still not working ??

Highlighted

Tested this morning and is now working 🙂 Thanks for your help @v-litu-msft 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Users online (7,555)