cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Link to SharePoint Library item not working as expected

Using the Sharepoint Trigger, "When a File is Created or Modified", I am trying to send an email containing a link to the file. Using the Outlook 365 action, "Send an Email" I select "link to Item" in the body of the mail. The working link to the file looks like this:

 

https://[].sharepoint.com/sites/Purchasing2/Sharepoint%20-%20Invoices/Broad%20Connect%20351.97%20%20201704%20%2082818.pdf

 

The link which is sent looks like this (yes, it is broken at the first %20):

https://[].sharepoint.com/sites/Purchasing2/Sharepoint - Invoices/Broad Connect 351.97 201704 82818.pdf

 

If I wrap 

 

Upon closer inspection, the working link has double spaces in some cases.....What is happening here? Links to List (as opposed to Library) items on our site work fine. 

6 REPLIES 6
Highlighted
Community Support
Community Support

Re: Link to SharePoint Library item not working as expected

Hi @RickBeec,

 

Do you mean the actual link contains the "%20" within it?

From your description, it seems Microsoft Flow would automatically convert the "%20" to the space.

 

Tkae a try to click the advanced option of the Send an Email Action, under Is HTML, select Yes.

See if that would make any difference.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Link to SharePoint Library item not working as expected

Hi,

 

Sharepoint does not add the %20 (space) but any browser converts spaces to it. I have tried the "send as HTML" as well as enclosing the Dynamic content in Double Quotes. 

Highlighted
Frequent Visitor

Re: Link to SharePoint Library item not working as expected

I have the same problem as well. Is there any plans to fix this? This pretty much makes Flows + SharePoint useless for me.

Highlighted
Frequent Visitor

Re: Link to SharePoint Library item not working as expected

Possible to get some feedback from the support team on this issue?

Highlighted
Frequent Visitor

Re: Link to SharePoint Library item not working as expected

Perhaps the team is unable to reproduce the problem. I can't beleive that more people are not using this awesome functionality?

Highlighted
Regular Visitor

Re: Link to SharePoint Library item not working as expected

HI, 

 

Is there any news on this? The only doens't work with PDF...

 

Thx.

 

Regards,

Soraia

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (5,884)