cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Managed Metadata only first file columns is correct on "Create file"

I have library with two MM columns, on "Get files (properties only)" the correct values for the files is pressent in "body", but on "Create file" in another Site Collection only one file columns has correct values, second, third etc file. has only correct value in one MM column. The value in the other column is "null" as "Create file" has taken a term set value from first column which is in the term set.

 

I have worked around this with an "Update file properties" after the creation, which works fine.

 

To reproduce:

Ttenant.sharepoint.com/SOURCE -> tenant.sharepoint.com/sites/DESTINATION.

Two Manged Metadata columns in both sites library same term sets.
Create File action   

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Managed Metadata only first file columns is correct on "Create file"

Hi @makp,

 

Could you please share a screenshot of the configuration of your flow?

Could you please explain more details about your scenes?

 

please share more details so we would try to reproduce you scenes.

 

Best regrads,

Alice

Highlighted
Frequent Visitor

Re: Managed Metadata only first file columns is correct on "Create file"

Hi @v-yuazh-msft

 

I am doing a flow which copies docx files from source tenant to uptill three other tenants and another flow will delete files in destination if needed, at the moment i am just copying in the boundaries of my own tenant betwen site collections:
tenant.sharepoint.com/CO (Subsite)
tenant.sharepoint.com/sites/destination (Root in another site collection)

In my source i have two managed metadata columns, ServiceType and Document, and on destination I have the same two MM columns - when all is set to go the i will replicate term store to the other tenants: https://docs.microsoft.com/en-us/sharepoint/dev/solution-guidance/multigeo-managedmetadata 

And for reference here is my flow:

 

 

flowa.PNG

 

flowb.PNG

 

The two "Publish" collapsed is the same as the uncollapsed, just with values for another tenant.

The uncollapsed "Update file properties" updates in source so not of interest.

From the "Get files (properties only)" i can see that the taxonomy data is correct, for the files:

   

First document:

      "Document": {
        "@odata.type": "#Microsoft.Azure.Connectors.SharePoint.SPListExpandedTaxonomy",
        "TermGuid": "TERMGUID",
        "WssId": 1,
        "Label": "FAQ",
        "Path": null,
        "Value": "FAQ|TERMGUID"
      },
      "Document#WssId": 1,
      "ServiceType": {
        "@odata.type": "#Microsoft.Azure.Connectors.SharePoint.SPListExpandedTaxonomy",
        "TermGuid": "TERMGUID",
        "WssId": 4,
        "Label": "Arena",
        "Path": null,
        "Value": "Arena|TERMGUID"
      },
      "ServiceType#WssId": 4,

Second document

   "Document": {
      "@odata.type": "#Microsoft.Azure.Connectors.SharePoint.SPListExpandedTaxonomy",
      "TermGuid": "TERMGUID",
      "WssId": 8,
      "Label": "Realease document",
      "Path": null,
      "Value": "Realease document|TERMGUID"
    },
    "Document#WssId": 8,
    "ServiceType": {
      "@odata.type": "#Microsoft.Azure.Connectors.SharePoint.SPListExpandedTaxonomy",
      "TermGuid": "TERMGUID",
      "WssId": 4,
      "Label": "Arena",
      "Path": null,
      "Value": "Arena|TERMGUID"
    },
    "ServiceType#WssId": 4,

 

 

If i leave out "Update file properties" the uncollapsed from the flow,

First document is OK, correct values in MM columns, but Second Document, only "Document" is correct the "ServiceType" it puts in value from first document "FAQ"
So the above would give me

document1.docx FAQ Arena

document2.docx Release Document  null (in library edit i can se its because it has used FAQ).

With a third and fourth document in the run, it gives Document correct value and ServiceType a value from the Document Termset


So basicly if there is two mm columns flow will only fill out one of them correctly in destination in Apply for each, for workaround i put in "Update file properties".

 

I have also tried to make the Destination columns as text and then only Document is filled correctly, but ServiceType is empty. 

 

 

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (8,821)