cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Microsoft Flow -> SendPushNotification-> Failed(The provided object identifier was null or missing)

I am continuously getting the following error (400 bad requests) while Sending a Push Notification using Microsoft Flow.

5 REPLIES 5
Highlighted
Frequent Visitor

Re: Microsoft Flow -> SendPushNotification-> Failed(The provided object identifier was null or

Same here---new to flow/powerapps (taking the Microsoft PowerApps course, in fact).

 

Here's what I get:

Flow error.jpg

 

 

Highlighted
Community Support
Community Support

Re: Microsoft Flow -> SendPushNotification-> Failed(The provided object identifier was null or

Hi @Sumitkhorana,

 

Before using the action Send push notification, have you created a connection to the app properly?

 

Please click the Connections, then create a connection to PowerApps notification with the proper URL or ID to the Target application.

 

Please check the following screenshot for a reference.

1.PNG

 

I have made a test on my side and it works fine.

2.PNG

3.PNG

 

Hope this doc on sending a notification from a flow could be your reference:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/add-notifications

 

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Microsoft Flow -> SendPushNotification-> Failed(The provided object identifier was null or

Yes, I tried using the URL and I tried using the AppID. Neither worked. I tried each twice, in fact. 4 failures.
Highlighted
New Member

Re: Microsoft Flow -> SendPushNotification-> Failed(The provided object identifier was null or

Hi @v-yamao-msft,

 

I did the same steps and did those a number of times but I am still getting the same.  I then thought may be i am getting this error since I had selected the Asia region. I then created a trail for United States region and again got the same error.  I am not sure whats wrong though. Afterwards, I thought may be App ID isnt working then I gave the Power App complete URL but again got the same failures. I took the Web Link and App ID from Details section of the Power App. 

 

Many Thanks. 

 

Regards,

Sumit

Highlighted
New Member

Re: Microsoft Flow -> SendPushNotification-> Failed(The provided object identifier was null or

I am not sure whats wrong but the connector started working without changing anything a couple of days later. 

 

Regards,

Sumit 

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (7,436)