cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Spinningball
Regular Visitor

Microsoft forms not triggering flow

Hello all!

 

We have a form that receives 100-200 submissions a day and for each submission the flow sends an email to the respondent with a formatted form response.

 

It worked perfectly up until just now,

 

I've tried copying the form and creating a duplicate as well as writing a new flow to connect to the new form.

 

No form submission seems to trigger the flow. I can trigger it with old data which does work, though.

 

Any suggestions or hypotheses as to why this might be happening?

 

Thanks !

1 ACCEPTED SOLUTION

Accepted Solutions
YashPatel
Microsoft
Microsoft

We are investigating this issue right now. This seems to be a non-isolated report. I will post updates here as I receive them.

Apologies for the inconvenience this issue may cause.

 

11:15am CST update: We have raised this with the product group and have engaged the right resources for investigation. I will update again as I receive more updates. 

12:05pm CST update: the product team is still investigating this issue. There will be a Service Health update posted shortly as well.

2:15pm CST update: we've restarted some services and responses should now slowly start flowing in. We do not expect missed responses to be processes by Flow. 

Final update 3:00pm CST: All Microsoft Forms responses should flow into Microsoft Power Automate successfully now. Please follow SHD# FL228460 in the M365 Service Health Dashboard for a full RCA in the next few days. 

For users with missed Forms responses, here is one possible way to processes these responses:

1. Duplicate the original flow;
2. Replace the trigger with "Manually trigger a flow", add a number input;
3. In "Get response details" action, replace the field in "ResponseId" with the number input of above trigger, and click "Save".
4. Then click "Run". In the "ResponseId" field, you can enter the ID of the responses which didn't trigger original flow.
5. The response ID can be found on form's "Responses" page, via exported Excel, or click "View results" button.

 

View solution in original post

35 REPLIES 35
NicoleHarris
Advocate I
Advocate I

Same is happening to me today all of a sudden. Going to post another post in case that helps get Microsoft's attention. 

kyleaskine
New Member

Same thing with us as well, started around 60-90 minutes ago.

leoTereza
New Member

Same here!!

RafaelOliveira
New Member

Same issue here..

noticed about 1 hour ago.

YashPatel
Microsoft
Microsoft

We are investigating this issue right now. This seems to be a non-isolated report. I will post updates here as I receive them.

 

Apologies for the inconvenience this issue may cause.

 

11:15am CST update: We have raised this with the product group and have engaged the right resources for investigation. I will update again as I receive more updates. 

GD20
Helper I
Helper I

I'm having the same problem--I've tried this with different forms and test flows. The trigger isn't firing when a new response is submitted. 

YashPatel
Microsoft
Microsoft

We are investigating this issue right now. This seems to be a non-isolated report. I will post updates here as I receive them.

Apologies for the inconvenience this issue may cause.

 

11:15am CST update: We have raised this with the product group and have engaged the right resources for investigation. I will update again as I receive more updates. 

12:05pm CST update: the product team is still investigating this issue. There will be a Service Health update posted shortly as well.

RafaelOliveira
New Member

Any news @YashPatel ?

YashPatel
Microsoft
Microsoft

We are investigating this issue right now. This seems to be a non-isolated report. I will post updates here as I receive them.

Apologies for the inconvenience this issue may cause.

 

11:15am CST update: We have raised this with the product group and have engaged the right resources for investigation. I will update again as I receive more updates. 

12:05pm CST update: the product team is still investigating this issue. There will be a Service Health update posted shortly as well.

2:15pm CST update: we've restarted some services and responses should now slowly start flowing in. We do not expect missed responses to be processes by Flow. 

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Users online (1,288)