cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Peter3010
Level: Powered On

Not getting flow approval email notification and flow stuck in running state

Hi Team,

 

I am facing very strange issue today. I have submitted a reqest which have approval and i didn't get any email notification for approval and the flow is stuck in running state.

 

Could you please advise some solution or workaround on this. Do i need to look for any other configuration in outlook? Till yesterday i am able to get approval email notifications? How can i check the flow services are up and running? Please advise i am stuck very badly. Screenshots below for refernce.

 

Poniters are on this is highly appreciated. Many thanks in advance!! 

 

flow.jpg

 

Flow state.png

4 REPLIES 4
Community Support Team
Community Support Team

Re: Not getting flow approval email notification and flow stuck in running state

Hi @Peter3010 ,

 

Could you share a screenshot on how the flow is configured in each step?

 

I have just made a simple flow using approval actions V1 and V2, both are working successfully.

1.PNG

 

Please share more details so that we could help reproduce the issue.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Peter3010
Level: Powered On

Re: Not getting flow approval email notification and flow stuck in running state

Hi Mabel,

 

Thanks for your reply.

 

While re-proing my issue at your end, you have used manual trigger and i am using one boolean condition say IsAdmin. If IsAdmin=true, then go for admin approval. This flag is coming/configured at entity level in CDS. I am getting the current record and checking whether the IsAdmin flag is true or flase and triggering the approval accordingly.

 

As requested, screenshot below for reference.  As you can see, flow is running from the last 1.5 hrs and yesterday i has the same case where it took 4.5 hrs approximately.

 

flow configuration.jpg

 

flow status as running.jpg

 

Peter3010
Level: Powered On

Re: Not getting flow approval email notification and flow stuck in running state

 

 

 Hi @v-yamao-msft 

No luck, still flow in in running state. Could you please advise what's going wrong with me. 

flow state 2.jpg

 

 

Community Support Team
Community Support Team

Re: Not getting flow approval email notification and flow stuck in running state

Hi @Peter3010 ,

 

Which entity are you using?

 

I am not sure which entity you are using to have a dynamic content IsAdmin, so I made a similar test with SharePoint list, which contains a Boolean column.

 

However, the issue still cannot be reproduced, it just works fine.

1.PNG

 

Could you try to recreate the flow to see if it will work?

 

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 365 members 6,675 guests
Please welcome our newest community members: