cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Not possible to add shared mailbox trigger

Hi,

 

I am not able to create a shared mailbox trigger in flow (full access granted for the connected user). The error is "The specified object was not found in the store., The process failed to get the correct properties." (see screenshot below).

 

Maybe it depends on the "Directory" name, but I'm trying a lot of other folders and variations here .. do you have any ideas? Any issues with german language? But when I open the shared mailbox via Outlook WebApp, I get this link for the inbox folder:

 

https://outlook.office.com/owa/info@xxxx.com/?offline=disabled&path=/mail/inbox

 

I also tried the "path" value, but without success.

 

Any ideas?

 

3 REPLIES 3
v-micsh-msft
Community Support
Community Support

Hi @Anonymous,

 

Please make sure the user account used for the trigger is a member of the Shared Mailbox.

Create a shared mailbox (Add member part)

"

The account that creates the connection inside of Micosoft Flow will need access to the mailbox to use this action.

"

For more information, check the blog below:

Work with Shared Mailboxes

 

Further, type the full Email Address of the Shared Mailbox, see if that would make any difference.

 

The Shared Mailbox trigger would work under my side:

23.PNG

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Encountering this exact problem -- if the email account specified is an actual account, the folder picker works fine. If the email account is blank, the folder picker displays folders of the current user.

 

However, if the email account specified is a Shared Mailbox (as you'd want... because it's a shared mailbox trigger), the folder picker fails.

 

 

Additionally there seems to be a UI bug where it inserts a semi-colon after the email address -- once the ; is in place, the folder picker fails on any account.

 

 

Figured it out, I had recreated the shared mailbox that I wanted to use by deleting it and then creating it again. I needed to clear out the old Shared Mailbox from the AD User recycle bin via AZAD powershell otherwise this error displays.

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Users online (81,133)