cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ianroseman
Advocate IV
Advocate IV

Post a Tweet Fails when trying to mention a Twitter user

When attempting to Post a Tweet with the following syntax, an error occurs:

 

 @@{body('Get_user')['UserName']}

 

with only one ampersand "@" the Post a Tweet works, but only has the name of the user, and not the "@" to make it a "mention"

1 ACCEPTED SOLUTION

Accepted Solutions
v-micsh-msft
Community Support
Community Support

Hi @ianroseman,

 

Thanks for the feedback.

It seems Flow would remove the @ symbol when the tweet string be sent to the Twitter API.

Tested with the Twitter API console, and the @ symbol works there.

I have send the feedback from our channel, and will post back if I got any response back.

 

Regards,

Michael

 

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
v-micsh-msft
Community Support
Community Support

Hi @ianroseman,

 

Thanks for the feedback.

It seems Flow would remove the @ symbol when the tweet string be sent to the Twitter API.

Tested with the Twitter API console, and the @ symbol works there.

I have send the feedback from our channel, and will post back if I got any response back.

 

Regards,

Michael

 

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

jewelden
Helper I
Helper I

Hi,

 

Could you click on a failed run in the run history and provide the browser URL?

You can send it directly to me:

jewelden at microsoft dot com.

 

For example, something like this:

https://flow.microsoft.com/manage/environments/8856deff-4160-49ca-a1eb-3668d02a4652/flows/60e6a830-1...60e6a830-109b-455f-a4fa-33c6f67827d8%2Fdetails&runStatus=Failed

 

Thanks,

Jeff

This turns out to have been a limitation of the twitter connector - they are intentionally stripping the @ symbol from tweet text with a comment that this is being done in order that Twitter not block our application. We are currently confirming that this is accurate, and if so, the connector team will update the documentation for this connector to call this limitation out.

 

Hi @ianroseman,

 

As @courtneo shared, mentioning someone for the Twitter Action in Microsoft Flow is not a supported scenario.

Which is documentated in the following page:

Twitter connector

Quoted the limits part:

"

LIMITS

The following are some of the limits and restrictions:

  1. Maximum number of connections per user: 2
  2. API call rate limit for POST operation: 12 per hour
  3. API call rate limit for other operations: 600 per hour
  4. Frequency of trigger polls: 60 seconds
  5. Maximum size of image upload: 5 MB
  6. Maximum size of video upload: 15 MB
  7. Maximum number of search results: 100

Additional restrictions for POST operation

Mentioning a @user while posting a tweet is not supported. Specifically, the "@" characters will be stripped while posting a tweet.

"

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Users online (62,327)