cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ChrisRPS
Level: Powered On

Posting a hyperlink on to MS Teams

Hi 

I am using a flow that will send a Sharepoint list item URL into a teams channel  e.g. <a href ="http://...."> Click here </a>. However when running the flow it will not post the hyperlink into the channel. It totally ignores it. The flow will run succesfully and will post the message correctly but will totally miss out the href link. I can post a hyperlink onto teams myself so it must be the transfer to teams from flow. 

I am using a template:  "Post a message to Teams for a selected item"

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Posting a hyperlink on to MS Teams

Hi @ChrisRPS,

 

Thanks for sharing the details. I think there is no problem with your flow configuration, please check the Teams setting on your side.

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Community Support Team
Community Support Team

Re: Posting a hyperlink on to MS Teams

Hi @ChrisRPS,

 

According to your description, I created a flow using the template “Post a message to Teams for a selected item”.

 

Without any customization on the template, I ran the flow for testing. It ran successfully and a message with the href link was posted on Teams. By clicking the link in the message body, I would be directed to the details of the selected item.

 

Please check the following screenshot:

1.PNG

 

You said that the message missed out the href link, could you show me a message that posted on Teams? How is the Message field configured in the flow?

 

Please show me more details on it.

 

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
ChrisRPS
Level: Powered On

Re: Posting a hyperlink on to MS Teams

Hi v-yamao-msft


This is the flow action that posts the message into teams.

 

Capture.JPG

So in Sharepoint Online, I include the message that I want to send over to Teams along with the item selected.

Capture1.JPG
Then click "Run Flow"

And in teams it only comes up with this.

Capture2.JPG
There is no hyperlink to click to go to the item. 

As it worked for you, it must be a setting or permissions that is preventing the link from appearing. Or I am missing something. The template hasn't changed from its default. 

Thanks

Chris 

Community Support Team
Community Support Team

Re: Posting a hyperlink on to MS Teams

Hi @ChrisRPS,

 

Thanks for sharing the details. I think there is no problem with your flow configuration, please check the Teams setting on your side.

 

Best regards,

Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

sbahl
Level: Power Up

Re: Posting a hyperlink on to MS Teams

What configuration setting do i need to check on the teams side? Please advise.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Users Online
Currently online: 220 members 5,697 guests
Please welcome our newest community members: