cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Jeff_Law
Frequent Visitor

Power Automate | New file not triggering flow any more

Hi

Over the last couple of months I have been creating some flows which trigger on the SharePoint "When a file is created (properties only). Then as from the 27th May, these have all stopped working. As in, adding a new file to the library does not trigger the flow. Because there is no trigger, then is no log (that I can find) which I can look at to find out why.

 

I have noticed that the Flow UI has been updated. 

 

I have spent the time today rebuilding one of my flows, from scratch to see if that fixes it, but no. Still not triggered. 

 

I have even created a flow with the SharePoint "When a file is created (properties only) trigger only, and it still doesnt get triggered when I upload a new file.

 

Other flows I have which are triggered by Power Apps run fine. It is just the SharePoint ones that I cant get working.

 

Has the latest change broken the SharePoint triggers?

Where can I look to see why they arent running? 

 

Regards

Jeff

`

 

5 REPLIES 5
v-litu-msft
Community Support
Community Support

Hi @Jeff_Law,

 

Could you create a Flow with a simple action to get file properties? For example:

Annotation 2020-05-28 155320.jpg

 If it couldn't work, the reason for the trigger not work is the connection is expired, please try to recreate a new SharePoint connection.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-litu-msft 

I created the simple flow you described and it worked fine. I triggered the flow run manually, and the item was read.

 

I have also gone through and checked the connections set up. All the Connections I use have the green tick

2020-05-29_11-31-12.png

So, I dont think its a problem with the connections.

 

However, I was doing some more testing, and I think I may have found something relevant. I use OneDrive to sync the SharePoint library to my local computer. When I want to upload a file to the library, I copy it to my OneDrive sync copy, and it gets uploaded. I have been doing things this way for years.

As a test, I uploaded a file to the SharePoint library using the web browser, and the Flow was triggered.

So, it looks like the problem relates to OneDrive syncing the files to the library. This process no longer invokes the new file trigger.

 

Regards

Jeff

PDRinoG
Advocate II
Advocate II

One year later and I have noticed today that this problem is happening again. This has always worked successfully. Now suddenly the flow is no longer triggered when I upload one or more documents in my file explorer to a SharePoint library that is synced with my PC. When I upload the same documents in the browser, directly in the SharePoint library, the flow is triggered!?

 

PDRinoG_0-1622577548966.png

 

mistaaah
New Member

I have also just started trying out power automate and i am testing ODB new file triger send email and it doesnt work from file explorer or drag & drop on webpage..

I asked my O365 admin and it seems the person affected wasn't assigned a licence for power automate. Waiting for licence to be provided, to verify.

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Kudoed Authors
Users online (2,122)