cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Power Automate | New file (randomly) not triggering flow

Hello,

 

I have created a flow in December 2018 to start a set of actions whenever a new file is uploaded to a certain library. One such action is to start an approval flow if the document matches the 'Invoice' content type.

 

That flow has worked (flawlessly, I thought) until ~March 2020 when I first the first notification of such an approval flow not being triggered. Looking back, I notice that in the last two months, randomly the flow is not triggered. Although I did update some details in the flow not too long before the moment where this inconsistency started, I did not touch the trigger itself.

 

I don't know where to find the 'Flow ID', but looking at the URL, this could be it: 5c6ba40a-d0ce-4ef3-a895-940b17802217

 

Any pointers?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @VincentVH ,

 

I suggest that you could create a new same flow to see if the new flow would work as expected.

 

Best regards,

Alice   

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Community Support
Community Support

Hi @VincentVH ,

 

Could you please share a screenshot of the configuration of your flow?

Have you check from the flow run history when the flow don't trigger?

Could you please take a try to create a new flow to see if the issue still exists? I'm afraid that there is any update on the trigger so the previous flow don't works, and the issue couldn't be confirmed on my side.

 

Best regards,

Alice   

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thank you, Alice, for your fast response.

 

If the flow is not triggered (which happens randomly), there is no run at all, and as a consequence there is no error information. This is the configuration of the Flow, as requested:

 

Aantekening 2020-05-27 115413.png

 

I checked for any 'trigger conditions' in the settings panel for that trigger, but there are none.

 

I created another Flow to find all Invoices that were not processed by this flow and was shocked to find that they go back to 8 March 2019... The number is limited (17 out of a total of ca. 500 invoices), which makes it even more difficult to notice.

 

Searching for solutions, I came along quite a few similar situations. Apparently the only sane conclusion is to ditch this trigger and to try out time-based or even manual triggers. So far the 'Power of Automation'...

Community Support
Community Support

Hi @VincentVH ,

 

I suggest that you could create a new same flow to see if the new flow would work as expected.

 

Best regards,

Alice   

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (9,421)