cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rabusiak
Level: Powered On

Sending HTTP request to Azure DevOps ends with 401 Unauthorized

My flow recently stopped working with 401 Unauthorized error. In one of it's steps it updates workitem with http request adding link to sharepoint in comment fileld. I set it up few months ago and it was working just fine.

I've already double checked all authorization related stuff such as setting it up with different user, with new pat etc.
Nothing helped so far.

I'm pretty sure it's not a problem with username/password/PAT since with exactly same settings I can add/modify/remove workitems in azure devops organization with powershell or postman. New updates in Flow itself could mess things up? When I create this flow there was no option "Body is Base64" at the bottom of the window.

1.png

 

 

4 REPLIES 4
Community Support Team
Community Support Team

Re: Sending HTTP request to Azure DevOps ends with 401 Unauthorized

Hi @rabusiak ,

 

Could you please share a screenshot of the flow run history when the flow run failed?

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

rabusiak
Level: Powered On

Re: Sending HTTP request to Azure DevOps ends with 401 Unauthorized

Hi @v-alzhan-msft,
The last failed run I can see in flow history is about week ago, but history is only for one month.
Other thing is that my run has condition at top, if sended mail doesn't have attachment the problematic http request is not in use. Basically I don't know when exactly it stopped working.

Community Support Team
Community Support Team

Re: Sending HTTP request to Azure DevOps ends with 401 Unauthorized

Hi @rabusiak ,

 

Please check the run details of the last failed run.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted
rabusiak
Level: Powered On

Re: Sending HTTP request to Azure DevOps ends with 401 Unauthorized

 

2.png

 

1.png

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (7,369)