cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

SharePoint Modified trigger strange behavior

I have a flow which I used for past 3 weeks it was working well until the recent Flow update.

I use PowerApps to modify and add new items to the SharePoint list. Before the update I used the SharePoint Modified trigger to send emails when an item was modified or a new item was created (there is a bug where SharePoint Modified triggers for new items making the SharePoint New trigger obsolete). After the Flow update I started to notice very strange behavior with that Flow. I noticed that it stopped to trigger when new items are added (Good) or items are modified through PowerApps (New Bug).

 

I had an extra flow with SharePoint New item trigger and it works good for new items created through PowerApps.

The SharePoint Modified trigger does not work on Items modified through PowerApps as it always appears under “Checks (No new data)” runs. 

 

Another interesting behavior is that the flow triggers automatically every hour without anyone touching any items in the list. The runs always appear in “Checks (No new data)” and is somehow triggered every hour.

 

Flows that were never triggered (how i know they were not triggered? It was night and I am the only one with access to that SharePoint list):

1.png
Output:

 

{
  "Pragma": "no-cache",
  "Retry-After": "3600",
  "x-ms-request-id": "9504ad1b-64d0-441f-93b0-a6509f342f3c",
  "Timing-Allow-Origin": "*",
  "Cache-Control": "no-cache",
  "Date": "Thu, 01 Jun 2017 05:19:35 GMT",
  "Location": "https://msmanaged-na.azure-apim.net/apim/sharepointonline/5b36bc45de37c22cfebd6e5a163730a2/datasets/https%253A%252F%252Faircanada.sharepoint.com%252Fsites%252FFPAPortal/tables/460f6b25-168d-43b8-af0f-49ea98ea2e21/onupdateditems?triggerstate=ZGF0ZXRpbWU9MjAxNy0wNi0wMVQwNToxOTozMlo7aWQ9MA==",
  "Set-Cookie": "ARRAffinity=1f30491caf7b12a0e335a9e466b30b4e592ee6878d560a4a3dae537edec32f67;Path=/;Domain=sharepointonlineconnectionprovider-westus.tip0-westus.p.azurewebsites.net",
  "Server": "Microsoft-IIS/8.0,Microsoft-HTTPAPI/2.0",
  "X-AspNet-Version": "4.0.30319",
  "X-Powered-By": "ASP.NET",
  "Content-Length": "0",
  "Expires": "-1"
}

 

TESTING

I went ahead and tried to experiment a little further. I created two new test flows one with trigger SharePoint new item and another one with SharePoint modify item. As soon as I created the flow I checked the runs (it should be 0), in the Successful runs it shows 0 however under the Checks (no new data) runs the flow with modifed trigger already triggered 7 times, while the new triggered 1 time.
Test flow modified item:
3.png

Test flow new item:

4.png


Anyways, I decided to test 4 scenarios.

Create a new item directly in SharePoint,

Create a new item through PowerApps,

Modify item directly in SharePoint,

Modify item through PowerApps.
I have my 4 flows (Old flow which triggers on SharePoint Modify, Old flow that triggers on SharePoint New, Test flow that triggers on SharePoint Modify, Test flow that triggers on SharePoint New)

 

Create a new item directly in SharePoint:
Old flow with SharePoint Modify trigger – triggered 2 times both completed successfully, one run triggered on new item, another run triggered on item modified previously – 2 bugs
Old flow with SharePoint New trigger – triggered 1 time and completed successfully – Correct Behavior
Test flow with SharePoint Modify trigger – triggered 1 time and completed successfully – Bug
Test flow with SharePoint New trigger – triggered 1 time and completed successfully – Correct Behaviour

Modify item directly in SharePoint:
Old flow with SharePoint Modify trigger – triggered but was skipped – Bug
Old flow with SharePoint New trigger – triggered but was skipped – Correct Behavior
Test flow with SharePoint Modify trigger – triggered but was skipped – Bug
Test flow with SharePoint New trigger – triggered but was skipped – Correct Behavior  

 

Create a new item in PowerApps:
Old flow with SharePoint Modify trigger - triggered but was skipped "Checks (no new data)"  Correct behavior
Old flow with SharePoint New trigger - triggered and executed successfully - Correct behavior
Test flow with SharePoint Modify trigger - triggered and executed successfully - Bug 
Test flow with SharePoint New trigger - triggered and executed successfully - Correct Behavior

Modify item in PowerApps:
Old flow with SharePoint Modify trigger – triggered 1 time and skipped - Bug
Old flow with SharePoint New trigger – triggered 1 time and skipped – Correct Behavior
Test flow with SharePoint Modify trigger – triggered 1 time and skipped - Bug
Test flow with SharePoint New trigger – triggered 1 time and skipped – Correct Behavior

 

 

 

Hope this helps the team to solve the issue.

1 REPLY 1
Community Support Team
Community Support Team

Re: SharePoint Modified trigger strange behavior

Hi @Anonymous,

 

Thanks for the detailed feedback!

Issue confirmed from our side.

 

We will send feedbacks on this and share the response once received.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,766)