cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Sharepoint List "Has Attachments" returns False when Limit by View

Hi,

I am building a Flow, I have a SharePoint List and have created a view due to the 12 lookup limit. When I add an attachment to a list item. It keeps returning False. The issue does not occur, if there is no view. I made a very simple flow and you can test it on your end.

Note: My workaround if this is a bug, is to use a "Get Attachments". but I prefer to lessen the actions.
Screenshot 1.PNG

 

Screenshot 2.PNG

 

screenshot 3.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Sharepoint List "Has Attachments" returns False when Limit by View

 

Hi @jian723 ,

 

I got a reply from Microsoft Support, it looks like a bug in either connector or SharePoint API.

 

The SharePoint Online connector is created based on the SharePoint API. I suggest that you submit similar questions in the SharePoint forum to see if similar problems can be reproduced when we make similar requests using the SharePoint API.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: Sharepoint List "Has Attachments" returns False when Limit by View

 

Hi @jian723 ,

 

Thank you for sharing. It seems that this is by design.

You are using the correct method to handle this situation.

Use Get attachments to check if the item contains the attachment.

58.PNG

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Sharepoint List "Has Attachments" returns False when Limit by View

Hi @v-bacao-msft,

Thank you for the support!. I have a workaround somehow the same like yours. But I do hope that we can get a clarification if this is really a "By Design".

 

 

Highlighted
Community Support
Community Support

Re: Sharepoint List "Has Attachments" returns False when Limit by View

 

Hi @jian723 ,

 

I will consult Dev on this matter, if there are any updates, I will post back.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Community Support
Community Support

Re: Sharepoint List "Has Attachments" returns False when Limit by View

 

Hi @jian723 ,

 

I got a reply from Microsoft Support, it looks like a bug in either connector or SharePoint API.

 

The SharePoint Online connector is created based on the SharePoint API. I suggest that you submit similar questions in the SharePoint forum to see if similar problems can be reproduced when we make similar requests using the SharePoint API.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (8,149)