cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper V
Helper V

Skype for business - Create an online meeting : ParameterValidationFailure

Hello There,

I have a big issue : my Skype for Business action is not working and the debug info are quite succinct.

Here is the screenshot of my test :skypeforbusinessBug.PNG

 

skypeforbusinessBug2.PNG

 

Here is the error message : 

Please check what you entered and try again.\r\nclientRequestId: 4c63011f-6fb2-4a94-b2a9-170c1c3aab72

Quite useful ! (not)

 

 

So could you please help me ? Thank you a lot.

 

Side question : how is it possible to not have to specify date and time for that specific meeting ?

4 REPLIES 4
Community Support
Community Support

Hi @Gaëlle,

 

Error code 400 means that your flow contains a setting in an action which doesn’t function as expected. Please check your flow configuration and make sure you have entered valid values.

I have made the following flow for testing, images for your reference:

1.PNG2.PNG

If you are still having the issue, please feel free post back.

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi Mabel,

I understood that, but I don't know where is the issue.

It could maybe reside in my Attendees emails ?

 

I have 2 different "Person or group" fields : "Additionnal resources" and "Referents".

I've initialised a string variable to get all the expected attendees email, called "AttendeesEmail".

To fullfill this string, I added an action "Add to a string variable", and by choosing the field to get, FLow built a "Apply to each" for each field.

So, my string ended like this :

AttendeesEmail : "referent1@mycompany.com;referent2@mycompany.com;referent3@mycompany.com;user1@mycompany.com;user2@mycompany.com;"

 

So, i don't get why Skype is failing, because it looks a lot like your Attendees field.

 

Is it because i've put strings in it ?

Or is it because my string ends with a semi-colon ?

 

Because, there is nothing else to it, I mean, all my flow is running well, until that last step where it fails.

And in the "Create an online meeting" action, I have done nothing "custom" except for that email string.

 

Can you please help me more, where did I failed?

 

Thanks a lot for your time.

Hi @Gaëlle,

 

Thanks for updating.

It seems that you are using variables in your flow and you have appended multiple email addresses into one.

Please try to set the variable as type of Array.

I have made the following test which is working properly.

Initialize variable of type Array, set its Name as Email.

After Get items, add an Apply to each, then Append to array variable within the apply to each. Please select dynamic content “EmployeeName Email” for the Value field.

Under the Apply to each, add a Compose action and input the following code:

join(variables('Email'),';')

In the action Create an online meeting, select Compose output for the Attendees field.

1.PNG 

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hello Mabel !

Thank you to provide me with a workaround, I tested it, but the Output of the Compose is the same as my AttendeeMail string and the error is the same :

Compose & Online Skype Meeting CreationCompose & Online Skype Meeting Creation

 

Apply to each to fulfill varApply to each to fulfill var

 

Initializing varInitializing var

 

Error part1Error part1

 

Error part2Error part2

 So, what else could I do ?

 

Thanks a lot.

Gaëlle

 

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (7,749)