cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
halcaide
New Member

Skype for business Integration error connection

Hi,

 

I have see the connector to Skype for Business (Preview). When i try ti sign, i get this error:

 

OAuth2CertificateSkypeForBusiness authorization flow failed for service 'Skype For Business Certificate'. Authenticated request to user's webdir discovery endpoint to find applications endpoint failed unexpectedly. Did not find 'redirect' nor 'applications' URI from _links object: expected={"_links":{"redirect":"USERWEBDIRURL"... or {"_links":{"applications":{"href":"USERAPPLICATIONSENDPOINT", found={ "_links": { "self": { "href": "https://webdir0e.online.lync.com/Autodiscover/AutodiscoverService.svc/root" }, "user": { "href": "https://webdir0e.online.lync.com/Autodiscover/AutodiscoverService.svc/root/oauth/user" }, "xframe": { "href": "https://webdir0e.online.lync.com/Autodiscover/XFrame/XFrame.html" } } }

 

Could you help me? we need this connector to use in app of room scheduler.

 

Thanks, 

Hector.

22 REPLIES 22
rdalle
Regular Visitor

Getting also this issue,
😞
what should be done in order to fix it?
AlexN
Advocate V
Advocate V

I guess there won't be a fix coming anymore since Skype for Business' functionalities will be integrated into Teams...

rdalle
Regular Visitor

I hope your assumption is wrong, because based on my readings, Skype for Business will keep living, whereas its capabilites are integrated into Teams

Does https://sched.lync.com work to schedule meetings with the same credentials? This will help eliminate on-prem hybrid setup issues.

Cameron
Microsoft
Microsoft

First, you should verify that https://sched.lync.com works.

 

Also be aware that on-prem skype is NOT supported.

 

AlexN
Advocate V
Advocate V

Hmm, that isn't working. So I guess we are on a on-prom installation of Skype (have to verify that with our sys admins...).

For Sharepoint we can use a gateway, this isn't available for Skype right? Too bad...

It appears there may be a way to enable this by configuring auto-discover for Skype... See this: https://ucwa.skype.com/documentation/GettingStarted-RootURL

Wow, this issue was first reported early in 2017. 

 

And I still get the problem now and the connector is still in Preview.

 

Just have a bad feeling about Flow, maybe SharePoint designer was great after all

I'm also in this situation but based on my understanding, the problem is not with Flow, the problem is regarding your skype for business setup. 

What I understood is ithe way your skype for business is configured within your IS (having a skype for Business O,n Premise is not enough it seems?)

Don't think it is that as our Skype for Business in O365, no on prem version installed.

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (2,141)