cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Some people on the team are getting an "API Hub token exchange internal server failure" when granting permissions to Planner

We are using a PowerApp inside Microsoft Teams to post items to Microsoft Planner, and some people in the team are getting errors authenticating while others are not. For those people where it fails, it consistently fails, so it's not an intermittent issue. It also happens in a browser session (InPrivate/Incognito). When they launch the PowerApp, they first have to grant PowerApps permissions to connect to Planner. They click "sign in" on that initial page (which doesn't actually prompt to sign in), then click the "Create" button (which does prompt to sign in), go through the sign in, and then have an "API Hub token exchange internal server failure":error.png

 

I've seen references to this error before on the forums but it was a platform issue in April that should have been resolved. However we're still getting this error now and for at least a week now (possibly much longer).

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Some people on the team are getting an "API Hub token exchange internal server failure" when granting permissions to Planner

 

Hi @jelledruyts ,

 

It seems that there is no part of Flow in your post, which seems to be the content of PowerApps.

Please check to see if you have submitted your issue to a community outside of expectations. If you want to ask questions about PowerApps, please consider submitting your questions in the community below:

https://powerusers.microsoft.com/t5/PowerApps-Community/ct-p/PowerApps1

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Some people on the team are getting an "API Hub token exchange internal server failure" when granting permissions to Planner

 

Hi @jelledruyts ,

 

It seems that there is no part of Flow in your post, which seems to be the content of PowerApps.

Please check to see if you have submitted your issue to a community outside of expectations. If you want to ask questions about PowerApps, please consider submitting your questions in the community below:

https://powerusers.microsoft.com/t5/PowerApps-Community/ct-p/PowerApps1

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
New Member

Re: Some people on the team are getting an "API Hub token exchange internal server failure" when granting permissions to Planner

Yikes, indeed, I somehow ended up in the Flow section instead of PowerApps where I originally started out - apologies. Have re-posted it here.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,008)