cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Submit Form Response to SharePoint List

Hi all,

 

I have an MS Flow that gets the replies from a MS Form and saves in a SharePoint Online List.

Sometimes the Flow runs successfully, sometimes it skips (no new data - Status Code: 202) in the first step which is gathering the Form replies and sometimes it doesn't even run at all.

 

 

Did anyone face something similar?

 

Cheers.

11 REPLIES 11
Highlighted
Community Support
Community Support

Hi @dbarrosstorm,

 

Actually, this is known issue and we are working on it. Unfortunately, No ETA from the MS Forms team on the fix. This apparently involves architecture changes so it may take a while. Sorry for the inconvenience.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper I
Helper I

I tried to have Microsoft Flow insert a line in an Excel spreadsheet and then notify the user by email that a new response had arrived in Micosoft Flow.  It has failed to trigger and I get Response status code 202 as well.  This was my initial foray into Microsoft Flow, which appears to hold much promise.  Unfortunately, I don't know what to do next.

Highlighted

Hi @v-monli-msft

 

Thanks for the update - when its fixed where will it be posted? Unfortunatly I have "sold" the senior staff a new solution that uses Forms -> Flow - I tested it and demoed it to them earlier in the summer when it was working. Its slightly frustrating that it has now stopped working.

 

I dont suppose you have a rough idea on how long "take a while" will roughly be?

Highlighted
New Member

This is very sad to heat.

 

Just like @Mattrog, I proposed as a solution to the HR director. I will have to create a form using SPFx, and give up about using Flow + Form. 

I also think there's a lot of promise in the solution. MS just need to have a faster approach for solving these issues. We're talking about an enterprise environment so a lot of money and/or value to the business might be lost there.

 

 

Highlighted
Advocate II
Advocate II

Interestingly I have had a newly created flow from a form work today ...

Have got limited chance to check it but I guess a fix might not be far off ?
Highlighted

Is there any progress on this issue? I too am having a critical failure when submitting an MS Form response. The Flow I created to populate the Form results into SP doesn't even activate. What's worse, is that there is no indication to the user (person filling out the form) that the Flow didn't trigger.

As noted above, this has serious implications on every organization going forward. After an automated process is implemented that sees a Flow link a Form to an SP list is standardized within an organization starts to fail, with no warning to the business is a critical failure. My system which I created was working, and now it is not. This devasting to MS reputation as confidence levels are severely affected.

What is the ETA for the fix?

Are there any short term measures? I've tried doing a "File Save As" on both the Flow and Form, which doesn't seem to fix the issue.

Please help,

Tom

Highlighted

My form -> flow now appears to be working ... I have used an old flow and a newly created one. The only issue at the moment is that there is sometime a 50 minute delay before the flow gets triggered...

 

I am guessing that this is the check point as it picks up any form entries that have been added but not "flowed" yet at that point.

 

Still testing today and will see how it goes

 

Matt

Highlighted

It would appear that MS is only triggering flows at approximately 39 minutes after the hour. I've been testing today and on 20 runs the flow was triggered at 39 minutes after the hour.

I also noted another issue. My flow uses the MS form information to populate a SP list. Once in the SP list it sends an email to a client. In 1 / 20 runs, the email did not send to the client. I verified that the email was correctly put in. So although the flow seems to be working, albeit quite delayed, there still seems to be an issue with Flow as witnessed.

 

Tom

Highlighted
Advocate II
Advocate II

The Flow Twitter account pointed me to the help page that states that forms get polled once every hour for new data https://docs.microsoft.com/en-us/connectors/microsoftforms/

That would line up with what you are seeing - not sure about the SharePoint write - did it trigger an error ?

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Top Solution Authors
Users online (12,981)