cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
chucksteel
Advocate I
Advocate I

Teams Cloud flow Save as copy not visible in Teams

Expected behavior: Using the Save as function creates a copy of the flow in the Team's environment that can be viewed in the PowerApps Teams app.

Actual behavior: The copy of the flow does not appear in the PowerApps Teams app.

 

Steps to reproduce:

  1. Open PowerApps Teams app
  2. Select the Build tab
  3. Click View all
  4. Click Cloud flows
  5. Click on a flow to open the details page
  6. Click Save As
  7. Click Save

The copy of the flow does not appear in the Build, Cloud Flows area. Opening the Power Automate app and changing the environment to the Team's environment does show the newly created copy of the flow, however.

 

8 REPLIES 8
RaashiSen
Community Support
Community Support

Thank you @chucksteel on informing this and with such detailed format. We will review it on our end and update the thread 🙂

mnexplorer
New Member

Hello - Any update on fixing this bug?  I will add that when save as is used, the original flow remains in the Build, Cloud Flows area and is not visible in the Power Automate app.  Result is the original flow is only accessible from Build, Cloud Flows area and the copy is only accessible from the Power Automate app, Team's environment.

I'm running into the same thing when using the Save As feature to try to create a copy of a Flow in Power Apps for Teams.  I don't see an error message or anything and the copy never appears in Teams.  If I go to the Power Automate service in Office 365 and switch to the environment that my app is published in, I can see the newly created Flow under "My flows". I suspect this is related to how solutions work in some way because I'm not able to go into the default solution for the environment and add the Flow there. 

 

Is there any workaround to this issue?

ToddBacon
Frequent Visitor

Same problem.

I also tried exporting it, renaming the existing flow, and importing it.  No luck.

mbrewer5
Regular Visitor

I am also having the same problem and would love a solution. Could the Power Automate developers provide a solution?

 

Thank you!

kgeusens
New Member

This seems like a bug.

When I log in to Power Automate Online (web) and switch to the environment of the team, the copy sits there.

However, that copy is not visable and therefor can not be used in the Teams environment

mbrewer5
Regular Visitor

Microsoft Power Automate - Will you please fix this bug? Otherwise, I would say Power Automate is an awesome tool. Thank you.

AJ007
Regular Visitor

Dear Microsoft any update? I am finding more and more reasons each day not to create Powersapp apps within a Team environment. 

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power automate tips 768x460 v2.png

Restore a Deleted Flow

Did you know that you could restore a deleted flow? Check out this helpful article.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

May UG Leader Call Carousel 768x460.png

What difference can a User Group make for you?

At the monthly call, connect with other leaders and find out how community makes your experience even better.

Top Solution Authors
Users online (1,857)