cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Re: Unable to process template language expressions in Custom Connector

@martinav it really is frustrating. No people pickers in my list, in fact, all columns are either single line or multiple lines of text columns as they're purely for reference after submission. I do have some JSON column formatting going on, but there's no logical reason as to why this would have any effect.

 

Just to update, this hasn't fallen over for the last few weeks. So I'm running tests hundreds of times a day with one eye shut. Still awaiting a response to my support ticket.

Highlighted
Advocate II
Advocate II

Re: Unable to process template language expressions in Custom Connector

This issue has happened to me quite a bit - different connectors, but the same error - a new step or modified step suddenly doesn't see the connector from before.

 

I believe I have the cause narrowed down, and it's definitely a bug. The action that 'corrupts' the flow for me every time: I change the action's connection, save/test, and now I get that error and it never goes away. Once I rebuild from scratch, it works as though nothing was wrong. I change a connection on any action - happens all over again.

 

Until Microsoft fixes this, I've been exporting my flows to back them up whenever I need to make any major changes - a backup copy helps because I can import to replace the corrupted copy in case any changes cause an action to corrupt again.

Highlighted
Resident Rockstar
Resident Rockstar

Re: Unable to process template language expressions in Custom Connector

@VictoriaH,

 

So, you are saying if you change the connection in "My Connections" (shown below), that is what has caused you the issue?  Do you know if it is 100%?

 

I have found a 100% flow corruptor is for a Sharepoint list.  If you add a People Picker column, your toast.  You have to at least delete your "Get Item" actions that call that list.  Of course, Get Item is tied to everything else, so you delete all tags referencing that action, and remake them.  Might be easier in some cases to start over.  

image.png

Highlighted
Dual Super User III
Dual Super User III

Re: Unable to process template language expressions in Custom Connector

@degvalentine

You saved my day!

Thankx for sharing!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Highlighted
Advocate II
Advocate II

Re: Unable to process template language expressions in Custom Connector

@martinav, so far my impression has been 50 to 75% of the time as I've not dedicated time towards confirming for 100%. I now avoid changing connections 100% of the time and have not once had the corruption happen since then. 

 

I'll look at spending 30 minutes towards confirming if it's 100% of the time with a few samples and different actions and connectors. I'll be back by Saturday with results.

Highlighted
Super User
Super User

Re: Unable to process template language expressions in Custom Connector

Hi @degvalentine !

Thanks for posting your workaround. My flow was "stuck" when I tried "Run from previous tests". I had to choose "I'll trigger".

Trigger type: Flow Button

Error message

Unable to process template language expressions in action 'Create_item' inputs at line '1' and column '2562': 
'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_sharepointonline_1']['connectionId']' cannot be evaluated
because property 'shared_sharepointonline_1' doesn't exist, available properties are ''.

Fix

  • When I clicked "I'll perform trigger action", I was prompted to allow Flow to use my Location in browser. Apparently this is because the Flow Button captures Lat/Long as part of its operation.
  • Clicking Allow worked here

image.png

Highlighted
Frequent Visitor

Re: Unable to process template language expressions in Custom Connector

I had the same issue with trying to add a task to a flow. I'm unable to a add a planner task or an outlook task does anyone have any ideas? Also where is the box to "assign" the tasks?

 

InvalidTemplate. Unable to process template language expressions in action 'Create_a_task' inputs at line '1' and column '2643': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_outlooktasks']['connectionId']' cannot be evaluated because property 'shared_outlooktasks' doesn't exist, available properties are 'shared_sharepointonline, shared_approvals'. Please see https://aka.ms/logicexpressions for usage details.'.

Highlighted
Helper III
Helper III

Re: Unable to process template language expressions in Custom Connector

This solution worked for me.  So much easier than recreating the Flow.  Very buggy.

Highlighted
Advocate I
Advocate I

Re: Unable to process template language expressions in Custom Connector

It appears to be Microsoft's solution - save your flow as a new one, then relink it to powerapps.

Mine broke because I was mucking about with connections.

https://support.microsoft.com/en-us/help/4477072/best-practices-updating-a-flow-used-by-a-powerapp

Highlighted
Advocate V
Advocate V

Re: Unable to process template language expressions in Custom Connector

I hit this problem again with a PowerApps trigger. Since this wasn't during Flow development (adding a new connector's action), my past solution of using the "I'll trigger this" option isn't viable.

 

I got around the terrible "delete/restore" solution by creating a new connection for the failing action - one with the same credentials as the failing one. As an added precaution, I also removed the old connection from the Flow by clicking on the "Share" dialog and clicking the "X" near the now unused connection.

 

Hopefully this spares someone out there struggling with this.

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,493)