cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dereklin
Frequent Visitor

Update item error

This is my workflow for my item update highlighted in yellow. Yesterday the flow was working perfectly but today it seems that it is giving me this error. Is this a bug?

 

it's either this error

{
  "status": 400,
  "message": "Could not parse lookup value.",
  "source": "https://jelglobal.sharepoint.com/sites/Intranet/_api/SP.APIHubConnector.UpdateListItem",
  "errors": [
    "-1",
    "Microsoft.SharePoint.SPConnectorException"
  ]
}

 or this error:

{
  "status": 400,
  "message": "User value is invalid.",
  "source": "https://jelglobal.sharepoint.com/sites/Intranet/_api/SP.APIHubConnector.UpdateListItem",
  "errors": [
    "-1",
    "Microsoft.SharePoint.SPConnectorException"
  ]
}

 

47 REPLIES 47
DaveM
Advocate I
Advocate I

I have the same error (User Value is Invalid).  Was working fine yesterday but not today.

I haven't changed anything.

iskaro
Regular Visitor

Same here. Yesterday it just stopped working. Any solution?

AlexGBC
New Member

My solution was:

Created Update item action BEFORE action with error. Resubmitted flow (no error were), deleted previously created action. Now works fine.

dereklin
Frequent Visitor

I tried that method too and It didn't work.

try to relink account which u use for action.

dereklin
Frequent Visitor

I created a new workflow with a different account and it still didnt work but somehow I realize that creating a SharePoint list without a lookup field works. The problem now is that it was working fine last week and this week, it gives me an error. 

 

Is there a workaround solution for this without having to re-create a SharePoint list without a lookup field? I need that for my workflow Smiley Sad

Anonymous
Not applicable

Our problems are not the same, but it seems that there are sufficient problems that causes many failures. I have seen creation failed, data fields blanked out and permission denied only to clear in a few minutes and then reoccur a little later.

Largomax
Helper I
Helper I

Hi,

 

I have the same issue on my flow. I try to recreat user connection on this flow but it still to doesn'n work.

Please I need a solution, this is our Holliday form..

{ "Pragma": "no-cache", "x-ms-request-id": "c1769669-6704-4edb-beef-6159c7210f7a", "Cache-Control": "no-cache", "Date": "Fri, 14 Apr 2017 10:05:16 GMT", "Set-Cookie": 

 

Path=/;Domain=127.0.0.1",
  "Server": "Microsoft-IIS/8.0,Microsoft-HTTPAPI/2.0",
  "X-AspNet-Version": "4.0.30319",
  "X-Powered-By": "ASP.NET",
  "Content-Length": "199",
  "Content-Type": "application/json; charset=utf-8",
  "Expires": "-1"
}
Body
{
  "status": 400,
  "message": "User value is invalid.",
  "source": "https://cloud4me.sharepoint.com/wandesk/_api/SP.APIHubConnector.CreateListItem",
  "errors": [
    "-1",
    "Microsoft.SharePoint.SPConnectorException"
  ]
}
Anonymous
Not applicable

I have the same problem but in Logic Apps. I ended up on this post after googling for "Microsoft.SharePoint.SPConnectorException"
 
Interestingly, I don't have this problem when creating the exact same workflow in Flow.
 
I also had a lookup field. I removed it and I had the same results.
 
I also created an update action before the failing action and I had the same results.
 

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Top Solution Authors
Users online (926)