cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Misa
Kudo Commander
Kudo Commander

Webpart is changing the flow of the document

Hello.

 

I have a flow that creates a PDF when a PowerApps form is saved.  The workflow works as intended and creates a PDF doccument in the document library.  The workflow also replaces the current PDF document if there is a document of the same name. 

 

When you go to the list via the List webpart and select the list item, edit and submit, it correctly creates a PDF document but it creates another document instead of updating the already existing document.

 

Is this a bug or considered "normal" behavior?

 

Thank you!

5 REPLIES 5
v-litu-msft
Community Support
Community Support

Hi @Misa,

Do you create a SharePoint connection via an on-premises data gateway?

If yes, I think the issue is about Migrating data files from SharePoint Server document libraries. You could refer to this document: 

https://docs.microsoft.com/en-us/sharepointmigration/how-to-use-the-sharepoint-migration-tool#using-...

You also could have a test that creates a connection of SharePoint online, then replace the file if it exist in the folder. 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-litu-msft 

 

Hi and thank you for your response.  Unfortuantely it doesn't have anything to do with migrating documents.  

 

I have a Sharepoint list that uses a custom PowerApps form.  When the user clicks Save on the form or Edit from the list, a flow is triggered that creates a PDF document from the HTML input text (essentially an HTML copy of the form).  If there is an existing document with the same name, it replaces the document.

 

On a page on the Sharepoint site, I use a list webpart that showcases the list items.  When you open the list item and Save/Edit, the same flow does creates the PDF in the same document library but it creates a 2nd document with the same name instead of replacing the existing PDF document with the same name.

 

The webpart is changing the behavior of the flow.  Is this normal?

 

Misa
Kudo Commander
Kudo Commander

@v-litu-msft 

 

Is this considered a bug or normal behavior?

v-litu-msft
Community Support
Community Support

Hi @Misa,

 

Sorry for the delayed reply, could you please share the workflow configuration and the same name files?

Normally, it should replace the file if there is a file of the same name except using copy file action with create a new file option.

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-litu-msft 

I am sorry.  I did not realize you had replied.  

 

Formula in Powerapps for the Sharepoint Form in the OnSuccess property (#1) SP Form Property.PNG

 

The other images are of the flow.

Flow 1.PNGFlow 2.PNG

Flow 3.PNG

Helpful resources

Announcements
Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Top Kudoed Authors
Users online (2,354)