cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jakekemme
Advocate IV
Advocate IV

When updating a Flow, inline functions render incorrectly for sharepoint choice field

On initial save, custom values have been entered for the sharepoint choice fields:

 

Flow2.JPG

 

When attempting to update (edit) the flow later, the functions revert to strings for the choice fields:

Flow1.JPG

 

4 REPLIES 4
v-yamao-msft
Community Support
Community Support

Hi jakekemme,

 

Thanks for feedback.

 

Please try to reenter the custom values for choice field to see if it will work.

 

Please provide a full screenshot of your flow and an URL of your flow for further investigation.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Yes, if works if I re-enter the text as a function again. The point of this ticket was to bring this exact problem to light.  I should not have to re-enter these functions into sharepoint list update actions every time I modify the flow.  If I save the flow without fixing them, the literal text, "trigger().outputs?.body...." is inserted as the value in the sharepoint list.

 

I'm not sure how a full screenshot or the url helps to 'further investigate' this. The step is a sharepoint 'Create item' action, and the fields affected by this are choice fields defined in the sharepoint site list, specifically when an inline function is used for the value.

 

Nevertheless, 

 

https://us.flow.microsoft.com/manage/environments/d03a7011-9b00-419d-8d5e-ca71fde9df49/flows/shared/...

 

Flow3.JPG

 

Hi jakekemme,

 

Thanks for the screenshot and flow URL.


What changes have you made on the flow?


Does this issue occur after you made changes on the flow then update it? If you do no changes on the flow configuration, will it occur?


I will be going to report this issue on my side.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Through some basic testing, it seems the original function intent is maintained.  The functions execute correctly as long as I do not change the string displayed in these boxes.

 

It appears to be contained to a display issue- This also causes a browser prompt to pop up when navigating away from the page saying I'll lose changes, even though I haven't changed anything within the flow.

 

This also may be related to the Compose step display issue reported here:

https://powerusers.microsoft.com/t5/I-Found-A-Bug/When-updating-a-flow-compose-function-incorrectly-...

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Users online (2,278)