cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

format item link in Flow approval email

When I insert a custom link for the Link in a Flow approval (ie. link that's not an existing dynamic content), it doesn't render correctly in the approval email.

 

flow format item link.png

 

As you can see in screenshot below, the item link description is split out from the item link, which also isn't rendered as a link. 

 

approval link email.png

 

I could ask users to view the original message and scroll down to get to the Link, but it's extra user training when the item link should render correctly in the first place. Also, the link renders correctly in the approval in Flow (both browser and app), so it's just the email where it doesn't render properly.

6 REPLIES 6
Highlighted
Community Support
Community Support

Re: format item link in Flow approval email

Hi rinagao,

 

Thanks for feedback.

 

I can reproduce this issue on my side.

 

In the Item link field, if a dynamic content Folder path is selected, the item link won’t split out from the item link. However, if an expression is entered in the item link field, in the actionable part of the approval email, the item link description will split out from the link. However, as you mentioned, in the original part of the email, the Browser and Mobile App, the link renders correctly.

 

I will help confirm this issue on my side and back to you once I got any response.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Anonymous
Not applicable

Re: format item link in Flow approval email

Hi Mabel,

 

Any updates on whether/when this will be fixed?

Highlighted
Frequent Visitor

Re: format item link in Flow approval email

We are experiencing the exact same issue in Outlook, but not for every user.  Seems Outlook has an issue (in some cases) with the format of the Link in the email.  Note, if the user selects "Forward" on the email, then the link renders fine.

Highlighted
Frequent Visitor

Re: format item link in Flow approval email

Looks like Outlook has a bug when you embed a link with a parenthesis in it during "Preview Mode".  You can verify this by clicking forward on the email.  While in "Edit Mode", the link renders in Outlook 365 latest build fine.

 

We worked around the bug by changing the link URL to use the Perma Link (Document ID) instead of the physical link (Link to Item) value.

Highlighted
Anonymous
Not applicable

Re: format item link in Flow approval email

When forwarding an approval, it forwards the original message (which has always formatted the link correctly), not the version with Outlook action.

 

I can use 'Link to Item' without any problems - it renders fine in the actionable email. However, I want to direct users to a folder in a document library instead (a link I have built in a variable), which causes this issue of not rendering correctly in the actionable email.

Highlighted
New Member

Re: format item link in Flow approval email

Any update on whether this bug is going to be fixed or not?  I'm experiencing the same issue.

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (10,141)