cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
amyhsieh11
Helper I
Helper I

get attachment from shared mailbox failed

Hi,

 

I create a automate that trigger by 'when a new email arrives in a shared mailbox (V2)'

then I'd like to get the attachment and use AI Builder to extract the content from that attachment.

but it's not working when the automate want to get the attachment...

 

All the process went well when I set the flow trigger by 'when a new email arrives' (personal email), I don't know why it cannot work once I change the trigger method?

 

I tried not to use 'get attachment' to get the file content, but it's not working on AI Builder, because AI Builder need the 'content byte' from 'get attachment'

 

amyhsieh11_0-1620198903880.png

 

 

amyhsieh11_1-1620197172516.png

 

 

amyhsieh11_2-1620197301696.png

  • also, I found that will be around 5 or more minutes lag between 'a new email arrives in a shared mailbox' and 'flow be trigger'amyhsieh11_4-1620198200309.png

     

    amyhsieh11_5-1620198274758.png

     

1 ACCEPTED SOLUTION

Accepted Solutions
JoeF-MSFT
Power Apps
Power Apps

Thanks for the additional details @amyhsieh11.

 

With Shared Mailbox it works the same way. There is no need to use the 'Get attachment' action, you can directly get the attachment content from the trigger as shown on the screenshot of my previous response. But here is an example with the 'Get attachment' option that should work. Can you check? Make sure you are putting the right ids on the 'Get attachment' action. 

 

JoeF-MSFT_0-1620215373246.png

 

View solution in original post

4 REPLIES 4
JoeF-MSFT
Power Apps
Power Apps

Hi @amyhsieh11,

Something you can try is structuring your flow like this to make sure it works this way and then customize it. 
Make sure you are setting to Yes the 'Include Attachments' option on the trigger. 

 

JoeF-MSFT_1-1620204567605.png

 

 

 

Hi @JoeF-MSFT 

 

thanks for your reply.

but as you see, the AI Builder cannot work with 'Attachments content'...

amyhsieh11_0-1620205752056.png

amyhsieh11_1-1620205780271.png

 

and your demo automate is triggered by 'when a new email arrives' not triggered by 'when a new email arrives in a shared mailbox'

 

→my question is 'get attachment' cannot work while the automate is triggered by 'when a new email arrives in a shared mailbox'

 

and I follow your suggestion to set following two options to YES, but it's still not working...

amyhsieh11_3-1620206194198.png

 

amyhsieh11_2-1620206174119.png

 

JoeF-MSFT
Power Apps
Power Apps

Thanks for the additional details @amyhsieh11.

 

With Shared Mailbox it works the same way. There is no need to use the 'Get attachment' action, you can directly get the attachment content from the trigger as shown on the screenshot of my previous response. But here is an example with the 'Get attachment' option that should work. Can you check? Make sure you are putting the right ids on the 'Get attachment' action. 

 

JoeF-MSFT_0-1620215373246.png

 

View solution in original post

Hi @JoeF-MSFT 

 

I don't know why but it ran successfully when I translate them all to English 😮

Thank you for your assistance with this matter. 😀

amyhsieh11_2-1620292367655.png

 

 

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Top Solution Authors
Users online (1,163)