cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
zeeshanamit
Frequent Visitor

"Start and Wait for Approval" email notifications seem to be broken

So I've been running a document approval flow for the past month and a half and it's worked perfectly fine. It's set up to wait for everyone to approve. But since yesterday it's been resending the same approve/reject email to the same user right after someone clicks on "Approve".

 

It appears that having a user click "Approve" seems to trigger more approval emails to be sent to the rest of the approvers. 

 

I tested the Start and Wait for an Approval connector with just a trigger and the approval connector itself and the same thing happens which means it's nothing I've done that's causing this behaviour. 

7 REPLIES 7
v-litu-msft
Community Support
Community Support

Hi @zeeshanamit,

 

I tested it on my side but not find the same issue. 

Did you add the Approval action from a template?

If did, please have a try that deletes the action then create it from the action list.

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

No i added the connector myself, not from a template. 

 

Did you try it with multiple approvers?

Here is a screenshot of the basic test flow i tested it with. I added two approvers to it. We both receive an approval email. Once approver 1 clicks "Approve" both of us get the same email sent to us again. 

zeeshanamit_0-1609133119311.png

 

Cat1
New Member

I am experiencing the same thing: The emails continue even after I have deleted the flow!!! Microsoft Support, can use fix this bug?? Thanks.

hdonato
Advocate I
Advocate I

Hi,

I am experiencing the same thing too. It sends approval email to the approver daily. Hope this bug will be fixed soon.

Hi @hdonato,

 

You could ask for the Power Automate support for further help:

https://preview.flow.microsoft.com/en-us/support/ 
Screenshot 2020-12-29 175354.jpg

 

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

JMAFO
Helper V
Helper V

Experiencing the same thing. A user reported receiving 6 notifications at once and then a 7th about five minutes later. 

jaszblemons
Regular Visitor

I'm having this issue too. As OP said : It appears that having a user click "Approve" seems to trigger more approval emails to be sent to the rest of the approvers. 

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Carousel

Sign up for our May 4th event!

May the fourth be with you, join us online!

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Users online (61,314)