cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SylvieLet17
Responsive Resident
Responsive Resident

"When a file is created or modified" Flow not Triggering with Copy To

Hi all, 

I noticed this bug around 6 months ago, and I put in a ticket with support but it still exists. 

I have reproduced it on several document libraries, and it always happens. 

I have a flow that runs on the trigger "When a file is created" and I also tried "When a file is created or modified" in Library B

When I copy a file from Library A to Library B, the flow triggers 9 out of 10 times, or randomly. 

I find that if it has been several hours since the last copy, the first file I copy to Library B never triggers the flow.  

I haven't tried this on another tenant, but I'm curious to see if anyone else can reproduce the issue. 

To reproduce properly though you need to try to trigger the flow MANY times because it is sporadic. At least more than 15. And I would suggest leaving it overnight and trying again in the morning. 

4 REPLIES 4
v-bacao-msft
Community Support
Community Support

Hi @SylvieLet17,

 

Do you mean that create a new file in the target library by using Copy to in another library, but trigger-When a file is created or modified is not triggered?

21.PNG

I created this Flow, and when I created a new file to library B using Copy to on library Copy, but Flow didn't work:

22.PNG

23.PNG

Flow run history does not have any records:

24.PNG

The strange thing is why I don't have any run history of Flow.

I think I need to do more tests. If confirmed, I will help report this issue on my side and back to you later.

 

Best Regards,

Barry

 

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

So the answer from Microsoft support is: this is by design.

Here is the response I received from them:

"As discussed with our technical advisors, copying file from library A to library B is not consistent  . For instance, it will take some time to copy the file in another library, and trigger is looking for some timestamp. This is the reason most of the times the flow does not triggered. The alternative workaround could be , copying files to library and use for selected item to trigger a flow."

 

So there will be no resolution to this. 

 

I don't fully understand, because if you run a recurring scheduled flow to check for all documents created in the last 24 hours - that works. So why can't the out of the box trigger "when an iteam is created" do the same for the past 5 minutes?

I'm not sure that is a good reason for inconsistant triggering.

I'm using this trigger to read a filesystem via on premise gateway to sync files to a sharepoint folder.

It seems to work well for file creation, but triggering on existing files being updated seems very hit and miss.

Not sure if this is a failure/configuration of the on premise gateway or the flow trigger but my sharepoint archive is getting stuck with out of date copies.  

Open to suggestions (new at this flow stuff)

Jennifer

Zuercherr
New Member

having the same issue with a .pdf document.

Copy once a day from Share to Sharepoint. Document has the same name.

Flow works when testing it, but woun't fire off, if scheduled.

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Carousel

Sign up for our May 4th event!

May the fourth be with you, join us online!

MSFTBizAppsLaunchEvent

Experience what’s next for Power Virtual Agents

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Users online (59,546)