cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Thorsten_L
Regular Visitor

unchanged flow suddenly creates empty arrays (filtered array) - occured 1st 19. August

Hi,

a workflow designed a few month ago, and working fine, suddenly produces empty arrays when filtering a sharepoint list by empty fields, and therefore creates an error (sorry I only have the german one):

"Vorlagensprachausdrücke in den Eingaben der Aktion "Aufgabe_erstellen" in Zeile "1" und Spalte "2898" können nicht verarbeitet werden: Der Vorlagensprachausdruck "variables('Projektnummern')[0]" kann nicht ausgewertet werden, da der Arrayindex "0" nicht aus einem leeren Array ausgewählt werden kann"

Like I said - all worked fine until 08/19/20 3 p.m.

Has there been an internal update?

1 ACCEPTED SOLUTION

Accepted Solutions

And this morning everything works again. I wonder what this was. Has there been an update?

View solution in original post

3 REPLIES 3
v-bacao-msft
Community Support
Community Support

 

Hi @Thorsten_L ,

 

Can you share a screenshot of the Flow configuration so that we can check the specific configuration?

 

Please check in the list whether there are items that meet the filter criteria.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thank you for your reply.

I am not quite sure what you mean by configuration. I add a screenshot of the 2 steps in the flow that read and filter the list, what leads to no result. I filter the list by empty fields in column "Projektname" and then want to pick the next free "Projektnummer" (column is filled) out of its column. Like I said - it worked fine for about 2 month, and suddenly didn't. a collegue told me, that there was ideed some kind of update by microsoft around this time, but I don't know any details.

In another flow I use an ODATA Filter within the "get list items", what still works.

 

flow filtered list.PNG

And yes - there are lots of entries that fit the filter criteria. I can think of another solution using the odata filter, but therfore I would have to rebuild the whole thing. I can't see any reason why this simple action in a bigger flow is not working anymore.

And this morning everything works again. I wonder what this was. Has there been an update?

View solution in original post

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Top Solution Authors
Users online (1,855)