cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
New Member

Collection created from CDS is blank

I have used collect(CollectionName, Accounts) to create and load the data from the Accounts collection, the outcome is the collection is created with columns but no rows. I know the Entity has data 

 

I actually want to do this for a custom Entity but using the Accounts entity as an example

9 REPLIES 9
Super User III
Super User III

Please can you show the formula for the Collection. Is it Onvisible or OnStart

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

First I tried the OnStart at the app level now I've got it on OnVisible on the screen, both have the same outcome.

 

thanks for your time, Ben

Use ClearCollect. Do you have some restrictions on your entity as a user?

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Ive tried both collect and clear collect, neither work on "OnStart" or "OnVisible" I can confirm I can  get it to work from a button tho.

 

I'm going to try a timer now it may achieve the same thing

OK Try with the Timer. Also do you check the data on a Gallery using the collection when you use the Onstart.

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

I found another post and the issue seems to be a bug, if you add a gallery that also connects to the same datasource as the collection  the collection will load with data.  also the timer works the same as onload and suits me better anyway and I need to refresh the collection periodically.

That is fine

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Community Support
Community Support

Hi @Bcoussens01 :

Could you tell me:

  • Does the Collect function in your OnStart and OnVisible not work?
  • Can you tell me what your test environment is?Is it in preview mode?

Regarding OnStart event, I suggest that you use the following methods for testing(In preview mode, OnStart event will not be executed automatically):

1.JPG

Regarding OnVisible event, I suggest that you use the following methods for testing:

Add an other screen and add a nevigate button,then nevigate to the target screen.(Only when navigating from another screen to the target screen, the OnVisible event property of the target screen will be executed.)

I hope my suggestions can help you.

Best Regards,

Bof

 

Super User II
Super User II

Hi @Bcoussens01,

CDS automatically filters the data based on your privileges. Are you sure that the user you're connected with has privileges to view all the CDS account data. Can you try with a system administrator account (CDS security role "System Administrator") just to isolate that this is not the issue?

Cheers 

Helpful resources

Announcements
secondImage

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

Users online (95,419)