cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Create Entity returing Generic SQL error

Community,
 
In the PowerApps web portal, I'm trying to create a new Entity in CDS, but I'm getting the following error:
The entity could not be provisioned. Please try saving to retry: Sql error: Generic SQL error. CRM ErrorCode: -2147204784 Sql ErrorCode: -2146232060 Sql Number: 2705.
 
First I try to create the Entity in a current Enviroment, but problem above appears. Than I create a new Enviroment and try the same process again, with the same result.
Anyone have an idea of what this error exactly means and How to fix it?
 
Thanks,
 
Daniel

1 ACCEPTED SOLUTION

Accepted Solutions

Thanks for replying. We manage to make it work, but the problem is related to the first field that is created with the Entity. if we change the name of the filed "Name", to any other thing, it fails. If I keep the name as it is for the field, it works fine.

 

Regards,

 

Daniel


@v-yutliu-msft wrote:

Hi @fuchsdanielti ,

I've made a test but not met the problem like your description.

Please check whether your account can use CDS.

What's more, I've found an idea about CDS troubleshooting tool which could help you solve the problem.

You could vote for him:
https://powerusers.microsoft.com/t5/PowerApps-Ideas/Common-Data-Service-Logging-and-Troubleshooting-...

If your problem still exists, please ask for help here:

https://powerapps.microsoft.com/en-us/support/

 

 

Best regards,

Community Support Team _ Phoebe Liu


 

View solution in original post

2 REPLIES 2
Community Support
Community Support

Hi @fuchsdanielti ,

I've made a test but not met the problem like your description.

Please check whether your account can use CDS.

What's more, I've found an idea about CDS troubleshooting tool which could help you solve the problem.

You could vote for him:
https://powerusers.microsoft.com/t5/PowerApps-Ideas/Common-Data-Service-Logging-and-Troubleshooting-...

If your problem still exists, please ask for help here:

https://powerapps.microsoft.com/en-us/support/

 

 

Best regards,

Community Support Team _ Phoebe Liu

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks for replying. We manage to make it work, but the problem is related to the first field that is created with the Entity. if we change the name of the filed "Name", to any other thing, it fails. If I keep the name as it is for the field, it works fine.

 

Regards,

 

Daniel


@v-yutliu-msft wrote:

Hi @fuchsdanielti ,

I've made a test but not met the problem like your description.

Please check whether your account can use CDS.

What's more, I've found an idea about CDS troubleshooting tool which could help you solve the problem.

You could vote for him:
https://powerusers.microsoft.com/t5/PowerApps-Ideas/Common-Data-Service-Logging-and-Troubleshooting-...

If your problem still exists, please ask for help here:

https://powerapps.microsoft.com/en-us/support/

 

 

Best regards,

Community Support Team _ Phoebe Liu


 

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Users online (8,895)